Bug 97997 - (YENTA PCI)Freeze while booting up newly up2dated version
(YENTA PCI)Freeze while booting up newly up2dated version
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
9
i386 Linux
high Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-25 05:59 EDT by Motoyuki Takeda
Modified: 2005-10-31 17:00 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 11:41:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci -vxx (4.64 KB, text/plain)
2003-07-03 22:59 EDT, Motoyuki Takeda
no flags Details

  None (edit)
Description Motoyuki Takeda 2003-06-25 05:59:21 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
While I boot up the newly up2dated version of Red Hat Linux [2.4.20-18.9], the 
display freezes all the time at the following:

Yenta IRQ list 06b8, PCI irq0
socket status: 30000007

What seems to be the problem?

Thank you.

Version-Release number of selected component (if applicable):
Red Hat Linux [2.4.20-18.9]

How reproducible:
Always

Steps to Reproduce:
1.Turn on the computer.
2.Booting display runs.
3.Freezes at the same position, described above.
    

Actual Results:  Trun off the computer.

Expected Results:  Red Hat Linux [2.4.20-18.9] can successfully boot up.

Additional info:

I have just up2dated the version to [2.4.20-18.9] from [2.4.20-8], which runs 
fine.
Comment 1 Alan Cox 2003-06-27 16:26:43 EDT
Looks like an irq funny but its odd even fi the tables were wrong that it should
change between -8 and -18 like that.

Does the new kernel boot fine with the "nopcmcia" option or hang later on ?
Comment 2 Motoyuki Takeda 2003-06-27 19:24:08 EDT
I'm not sure how to detect pcmcia, however, as long as -8, it successfully 
boots and works fine.  Does it make sense?
Comment 3 Motoyuki Takeda 2003-06-30 02:10:13 EDT
I would like to remove the -18.9.  However, as it freezes amid the booting,
I cannot even delete it from my computer!  Is there any ways to delete -18.9
successfully from my computer even in this occasion?
Comment 4 Alan Cox 2003-06-30 11:58:18 EDT
Does the new kernel boot fine with the "nopcmcia" option or hang later on ?
Comment 5 Motoyuki Takeda 2003-06-30 18:50:27 EDT
Again. as long as -8, it successfully boots and works fine with a LAN card.
Am I responding to your question? 
Comment 6 Alan Cox 2003-06-30 18:56:01 EDT
I need to know what happens if you boot the -17 update with the option "nopcmcia"

(Boot menu hit "e" add " nopcmcia", then boot  the -17 kernel
Comment 7 Motoyuki Takeda 2003-06-30 19:37:28 EDT
You mean "-18.9" to which I was updated instead of "-17" which you mentioned?
Comment 8 Motoyuki Takeda 2003-06-30 20:57:13 EDT
Although I tried booting -18.9 following to your instruction, I failed to boot
and it freezed with the following message:

Kernel panic: No init found.  Try passing init= option to kernal. 
Comment 9 Motoyuki Takeda 2003-07-01 14:57:26 EDT
The result was shown above.  Do you recommend that I should remove -18.9, or
still keep trying fixing?
Comment 10 Alan Cox 2003-07-01 15:17:38 EDT
I think removing it may be best.  I don't know why it fails but the problem is
not simple it seems.
Can you attach "lspci -vxx" output please.

Comment 11 Motoyuki Takeda 2003-07-01 15:35:33 EDT
I see.  How can I attach "lspci-vxx" output?  Could you tell me what kind of
operations I need to take?  Also, could you show me how to remove -18.9?  I
need your instructions.
Comment 12 Motoyuki Takeda 2003-07-01 17:13:33 EDT
I need your instructions.
Comment 13 Motoyuki Takeda 2003-07-02 09:19:49 EDT
Could you teach me how to successfully remove -18.9, letting -8 remain, from
the _boot menu_?  Since it does not boot, the only command I can do is one from
the boot menu.  Please!
 
Comment 14 Motoyuki Takeda 2003-07-02 14:31:09 EDT
I am waiting for your reply regarding above.  Thank you.
Comment 15 Motoyuki Takeda 2003-07-03 15:01:44 EDT
How can I remove -18.9 from the boot menu???  Please let me know promptly. 
Thank you.
Comment 16 Motoyuki Takeda 2003-07-03 22:59:35 EDT
Created attachment 92754 [details]
lspci -vxx
Comment 17 Alan Cox 2003-07-05 09:29:09 EDT
I've been away.

Before you remove -18.9 make sure one of the other kernels in the boot menu works
Boot the other kernel
As root
"rpm --erase kernel-2.4.20-18.9"

That should do it
Comment 18 Alan Cox 2003-07-05 09:30:05 EDT
Appears to be an IRQ handling problem. The driver assumes the chip is either
doing ISA or PCI mode interrupts but it may not be. 
Comment 19 Motoyuki Takeda 2003-07-05 10:38:07 EDT
So sorry, but I was not able to remove -18.9 successfully.  Putting the command
"rpm --erase kernel-2.4.20-18.9" on the _root terminal_ of the other booted
kernel, right?  A line shown as _command not found_ appears.  If I was wrong,
please point it out, and suggest what to do a bit more specifically; for
instance, no, no, go to the boot menu and hit _ , and put the command line at
where, or something...  
Comment 20 Alan Cox 2003-07-05 11:27:07 EDT
After you logged in as root yes

rpm --erase kernel-2.4.20-18.9

If that doesn't work then sorry I don't know what is going on
Comment 21 Motoyuki Takeda 2003-07-05 13:52:40 EDT
I finally killed -18.9.  Thank you for your support.  BTW, I found that so
many Web Sites indicated that exactly the same problem occurs with Toshiba lap
top PCs.  This problem might not be on a bug but on a chemistry between
YENTA and the hardwear.  
Comment 22 Paulo Calçada 2003-12-04 06:58:29 EST
Hello.
I have the same problem in FEDORA CORE 1.
I already tried the nopcmcia, but the problem remained.

Can you help?
Thanks.

Paulo Calçada
Comment 23 Bugzilla owner 2004-09-30 11:41:12 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.