Bug 979983 - Missing configuration description and examples for HornetQ large messages (section 17.5)
Missing configuration description and examples for HornetQ large messages (se...
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Documentation (Show other bugs)
6.1.1,6.3.0
Unspecified Unspecified
unspecified Severity urgent
: GA
: EAP 6.3.0
Assigned To: Nidhi
Martin Svehla
: Documentation, FutureFeature, Triaged
: 832031 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-01 05:16 EDT by Martin Svehla
Modified: 2014-08-14 11:18 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-28 11:26:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker JBQA-9648 Major Open Section on Large Messages needs to be extended 2014-07-31 08:12:23 EDT

  None (edit)
Description Martin Svehla 2013-07-01 05:16:54 EDT
Document URL: http://documentation-devel.engineering.redhat.com/docs/en-US/JBoss_Enterprise_Application_Platform/6.1/html/Administration_and_Configuration_Guide/Work_with_Large_Messages1.html

Section Number and Name: 17.5. Work with Large Messages

Describe the issue: 
Configuration of large message settings for HornetQ is missing.

Suggestions for improvement: 
There should be description on large message configuration parameters alongside some examples in section 17.5 of EAP documentation.

Additional information: 
See http://docs.jboss.org/hornetq/2.3.0.Final/docs/user-manual/html_single/index.html#large-messages for upstream documentation on large messages (mostly sections 23.1 and 23.2)
Comment 7 Martin Svehla 2014-04-30 03:21:57 EDT
Nidhi,

Thanks a lot for writing the text! I would like few changes though:

(1) In 17.5.2 the sentence with default path needs to be fixed. Something like:

"$JBOSS_HOME/standalone/data/largemessages is the default directory for storing large messages in standalone mode, while $JBOSS_HOME/domain/servers/SERVERNAME/data/largemessages is the default directory for large messages in domain mode."

(Not sure whether it's better to use $JBOSS_HOME or EAP_HOME as a root EAP directory, document as a whole is a bit inconsistent in this.)

(2) Create new paragraph at the end of 17.5.2 mentioning that storing large messages on different hard drive than journal can yield better performance:

"For the best performance we recommend large messages directory is stored on a different physical volume to the message journal or paging directory."

(3) In 17.5.3 rename chapter "Using HornetQ Core API" to "Using HornetQ Core API on client side". In the text, add sentence mentioning default value for setMinLargeMessagesSize, something like: "By default, minimum size of large messages is set to 100KiB."

(4) In 17.5.3 rename chapter "Using Java Messaging Service (JMS)" to "Configuring server for JMS clients".

Server configuration file name needs to be fixed (hornetq-jms.xml is only for standalone HornetQ server):

"...specify the minimum size of large messages in the attribute min-large-message-size in server configuration file (e.g. standalone.xml or domain.xml)."

Also, again please add a mention that the default value is 100KiB and that the value in the configuration file has to be in bytes.

In the configuration example, please add min-large-message-size attribute as well so the example contains both mentioned settings options:

<connection-factory name="ConnectionFactory">
  <connectors>
    <connector-ref connector-name="netty"/>
  </connectors>
  ...
  <min-large-message-size>204800</min-large-message-size>
  <compress-large-messages>true</compress-large-messages>
</connection-factory>
Comment 9 Martin Svehla 2014-05-06 11:06:59 EDT
(Changes are already on staging)

Looks good now Nidhi, thanks!
Comment 10 Miroslav Novak 2014-07-21 04:39:03 EDT
*** Bug 832031 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.