Bug 980153 - [RFE] rlFileBackup --clean by default
[RFE] rlFileBackup --clean by default
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: beakerlib (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Petr Muller
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-01 10:40 EDT by Dalibor Pospíšil
Modified: 2016-09-19 22:10 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-02 10:44:12 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dalibor Pospíšil 2013-07-01 10:40:24 EDT
What about setting --clean as default behavior? I would guess that this will not cause problems.

If the problem is that rm -rf is called before it could be done in more intelligent way like remove only new files and restore the rest, see bug 961623.
Comment 1 Petr Muller 2013-07-15 12:18:34 EDT
Why do this? What will get better? I need some arguments for the change.

--clean is not safe to call universally, and I do not want to make it "safer" because it is complicated enough already. That's my argument for not doing it.
Comment 2 Dalibor Pospíšil 2013-07-16 08:44:44 EDT
I think that it is just obvious.

When I did not know about --clean option I assumed that it is the default so a lot of my tests does not use it which is sometimes wrong.

But I must agree that from backward compatibility point of view it is not very safe.
Comment 3 Petr Muller 2013-12-02 10:44:12 EST
Not backward compatible, I'm not convinced to do it.

Note You need to log in before you can comment on or make changes to this bug.