Bug 980158 - UserNames with i18n charactes cannot login successfully even with valid credentials.
UserNames with i18n charactes cannot login successfully even with valid crede...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.0.1
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: Marek Hulan
Hayk Hovsepyan
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-01 10:49 EDT by Apurva Bhole
Modified: 2014-04-24 13:12 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Apurva Bhole 2013-07-01 10:49:38 EDT
Description of problem:
When trying to login a valid user that contains i18n characters in the username and/or password, the authentication fails.


How reproducible:
Everytime

Steps to Reproduce:
1. Login as Admin 
2. Create a username "novýuživatel" 
3. Logout
4. Login with the credentials of the newly created user

Actual results:
We're sorry, but something went wrong.

Expected results:
Based on whether the credentials are valid or invalid, the result should be either a successfull login or an "Authentication failed, try again" message.

Additional info:
This login feature works good with the CLI.
Comment 2 Eric Helms 2013-10-08 14:55:21 EDT
Tracking upstream - https://github.com/Katello/katello/pull/3129
Comment 3 Petr Chalupa 2013-10-15 10:24:01 EDT
previous comment belongs to another bug, changing back to NEW
Comment 4 Walden Raines 2013-10-15 11:59:46 EDT
This only happens with signo.  Logging in as the above user in katello works as expected.
Comment 7 Walden Raines 2013-10-15 17:38:12 EDT
The bug appears to be on the katello side as signo has the user logged in correctly, changing component.
Comment 9 Marek Hulan 2013-10-16 04:02:13 EDT
Actually both components need a fix. Here are the fixing PRs
https://github.com/Katello/katello/pull/3191
https://github.com/Katello/signo/pull/22
Comment 10 Walden Raines 2013-10-16 09:41:14 EDT
Reassigning to Marek since he already has PRs in.
Comment 14 Hayk Hovsepyan 2013-10-21 09:12:47 EDT
Verified on revision:
Katello-Katello-Installation-RegisterRHNClassic-1.1-4.noarch
foreman-postgresql-1.3.0-18.el6sat.noarch
candlepin-scl-runtime-1-5.el6_4.noarch
apr-util-ldap-1.3.9-3.el6_0.1.x86_64
openldap-2.4.23-31.el6.x86_64
pulp-nodes-common-2.3.0-0.22.beta.el6sat.noarch
candlepin-scl-1-5.el6_4.noarch
elasticsearch-0.19.9-8.el6sat.noarch
katello-glue-candlepin-1.4.6-40.el6sat.noarch
candlepin-tomcat6-0.8.25-1.el6sam.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
Katello-Katello-Configuration-KatelloClient-1.1-53.noarch
Katello-Katello-Installation-Satellite6Latest-1.0-13.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-qpid-client-key-pair-1.0-1.noarch
foreman-1.3.0-18.el6sat.noarch
katello-cli-common-1.4.3-24.el6sat.noarch
pulp-selinux-2.3.0-0.22.beta.el6sat.noarch
python-ldap-2.3.10-1.el6.x86_64
katello-certs-tools-1.4.4-1.el6sat.noarch
pulp-server-2.3.0-0.22.beta.el6sat.noarch
pulp-katello-plugins-0.2-1.el6sat.noarch
pulp-nodes-parent-2.3.0-0.22.beta.el6sat.noarch
candlepin-scl-quartz-2.1.5-5.el6_4.noarch
candlepin-selinux-0.8.25-1.el6sam.noarch
signo-katello-0.0.23-2.el6sat.noarch
katello-glue-pulp-1.4.6-40.el6sat.noarch
katello-selinux-1.4.4-4.el6sat.noarch
katello-1.4.6-40.el6sat.noarch
katello-configure-foreman-1.4.7-6.el6sat.noarch
katello-all-1.4.6-40.el6sat.noarch
ruby193-rubygem-ldap_fluff-0.2.2-2.el6sat.noarch
foreman-proxy-1.3.0-3.el6sat.noarch
pulp-rpm-handlers-2.3.0-0.22.beta.el6sat.noarch
katello-agent-1.4.4-3.el6sat.noarch
Katello-Katello-Installation-HammerCLI-1.0-9.noarch
katello-cli-1.4.3-24.el6sat.noarch
candlepin-scl-rhino-1.7R3-1.el6_4.noarch
katello-configure-1.4.7-6.el6sat.noarch
pulp-puppet-plugins-2.3.0-0.22.beta.el6sat.noarch
pulp-rpm-plugins-2.3.0-0.22.beta.el6sat.noarch
candlepin-0.8.25-1.el6sam.noarch
ruby193-rubygem-net-ldap-0.3.1-3.el6sat.noarch
katello-common-1.4.6-40.el6sat.noarch
katello-glue-elasticsearch-1.4.6-40.el6sat.noarch
katello-foreman-all-1.4.6-40.el6sat.noarch
candlepin-cert-consumer-hades.usersys.redhat.com-1.0-1.noarch
signo-0.0.23-2.el6sat.noarch
Katello-Katello-Sanity-ImportKeys-1.2-1.noarch
Comment 16 Bryan Kearney 2014-04-24 13:11:17 EDT
This was verified and delivered with MDP2. Closing it out.
Comment 17 Bryan Kearney 2014-04-24 13:12:13 EDT
This was delivered and verified with MDP2. Closing the bug.

Note You need to log in before you can comment on or make changes to this bug.