Bug 98016 - service sendmail reload does a restart
service sendmail reload does a restart
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: sendmail (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Florian La Roche
David Lawrence
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-25 11:19 EDT by Stephen Samuel
Modified: 2007-04-18 12:55 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-13 04:35:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch for /etc/rc.d/init.d/sendmail (580 bytes, patch)
2003-06-25 11:24 EDT, Stephen Samuel
no flags Details | Diff
New patch for /etc/rc.d/init.d/sendmail (990 bytes, patch)
2003-06-25 19:30 EDT, Stephen Samuel
no flags Details | Diff

  None (edit)
Description Stephen Samuel 2003-06-25 11:19:36 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030529

Description of problem:
I expect `service sendmail reload` to simply reload sendmail.
Instead, it does a complete shutdown and restart.
I realize that the difference is somewhat minimal, but why not 
be correct?



Version-Release number of selected component (if applicable):
sendmail-8.12.8-5.90

How reproducible:
Always

Steps to Reproduce:
1. service sendmail reload
2.
3.
    

Actual Results:  Shutting down sendmail:                                    [  OK  ]
Shutting down sm-client:                                   [  OK  ]
Starting sendmail:                                         [  OK  ]
Starting sm-client:                                        [  OK  ]


Expected Results:  reloading sendmail:                                        [
 OK  ]
reloading  sm-client:                                      [  OK  ]


Additional info: Patch included (next)
Comment 1 Stephen Samuel 2003-06-25 11:24:31 EDT
Created attachment 92611 [details]
Patch for /etc/rc.d/init.d/sendmail
Comment 2 Florian La Roche 2003-06-25 19:00:41 EDT
*** Bug 84165 has been marked as a duplicate of this bug. ***
Comment 3 Oliver Schulze L. 2003-06-25 19:09:28 EDT
Please respect presedence of bugs.
Bug #84165 was created before this bug.
Comment 4 Stephen Samuel 2003-06-25 19:30:17 EDT
Created attachment 92623 [details]
New patch for /etc/rc.d/init.d/sendmail 

now also does database rebuilds
Comment 5 Oliver Schulze L. 2003-06-25 19:49:17 EDT
This bug is very similar to bug #84165. Because what the reporter really wants
is a real reload function.
The reload function is mean to tell a running service to reread all config files.
This includes all files in /etc/mail
The file /etc/aliases already have a mean for reloading(i.e. newaliases)
Comment 6 Oliver Schulze L. 2003-06-25 20:14:00 EDT
Great patch.
You have fixed bug #84165
I don't know if your patch should go to this bug(RH9) or the bug #84165 (RH7.3)
Will try to port your patch to RH7.3
Comment 7 Oliver Schulze L. 2003-06-25 20:24:24 EDT
Regarding the 2nd attach:
- there is a call to the daemon function in reload
- maybe the RETVAL should be checked before the sm-client is reloaded:
  if [ $RETVAL -eq 0 ] && [ -f /var/run/sm-client.pid ] ; then
    # Reload sm-client
- if $RETVAL is defined outside the reload funtion, there is no need to asing
the exit code of the reload function the case() statement:
  reload)
	reload
	;;


I finished porting the patch to RH7.3, will test and post the patch in a few
minutes.
Comment 8 Thomas Woerner 2004-01-13 04:35:25 EST
Fixed in rawhide in rpm sendmail-8.12.10-7 or newer.

Note You need to log in before you can comment on or make changes to this bug.