Bug 980204 - Snapshot Error
Snapshot Error
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: systemd-ui (Show other bugs)
19
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-01 13:26 EDT by KitchM
Modified: 2013-12-28 18:37 EST (History)
4 users (show)

See Also:
Fixed In Version: systemd-ui-3-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-28 18:37:10 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Take Snapshot error (144.12 KB, image/png)
2013-07-01 13:26 EDT, KitchM
no flags Details

  None (edit)
Description KitchM 2013-07-01 13:26:16 EDT
Created attachment 767457 [details]
Take Snapshot error

Description of problem: Selecting "Take Snapshot" button causes error message


Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1.Open program
2.select Take Snapshot
3.

Actual results:
Give error

Expected results:
Don't know - never worked

Additional info:
Comment 1 Michal Schmidt 2013-07-01 14:06:04 EDT
The error is AccessDenied. Creating a snapshot is a privileged operation.
I agree it's not pretty to show the raw error from DBus.
I wouldn't expect an improvement anytime soon. systemadm is not getting much developer attention.
Comment 2 KitchM 2013-07-02 00:03:19 EDT
That sounds good on the surface, but is of course wrong.  I do have privileges.  So it must be a false error.

And I couldn't agree more that the program is having problems, because it is clearly obvious that it isn't getting the proper attention.  It is in a very bad state at this point of its development.  In fact, I'm not sure why it has been released.

On the other hand, what takes its place?
Comment 3 Michal Schmidt 2013-07-02 05:51:45 EDT
(In reply to KitchM from comment #2)
> In fact, I'm not sure why it has been released.

"Release early, release often". At the time of the tool's release it was not predicted that the developers' focus would shift elsewhere.

> On the other hand, what takes its place?

The command line tools: systemctl, systemd-analyze
Comment 4 KitchM 2013-07-03 12:37:17 EDT
GUI, GUI; we need gui program!
Comment 5 KitchM 2013-07-04 14:54:30 EDT
No idea what systemd-analyze is telling me.  Had to use systemctl on another bug and it helped with explaning services status.

I will start looking for a better system program.  There must be one out there.

I will also work to get systemd-ui put back into the testing repo.
Comment 6 Fedora Update System 2013-12-19 20:43:02 EST
systemd-ui-3-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/systemd-ui-3-1.fc20
Comment 7 Zbigniew Jędrzejewski-Szmek 2013-12-19 20:44:09 EST
DBus errors are translated to errnos using the same mapping as upstream systemd. strerror() message will now be shown as the main message, and the dbus error details as the secondary message.
Comment 8 Fedora Update System 2013-12-20 21:29:53 EST
Package systemd-ui-3-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing systemd-ui-3-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-23755/systemd-ui-3-1.fc20
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2013-12-28 18:37:10 EST
systemd-ui-3-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.