Bug 980215 - simplified Chinese formal digit for six (liu, 4th tone) not available.
simplified Chinese formal digit for six (liu, 4th tone) not available.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ibus-pinyin (Show other bugs)
18
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Peng Wu
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-01 14:14 EDT by Bill
Modified: 2013-11-10 01:55 EST (History)
4 users (show)

See Also:
Fixed In Version: libpinyin-0.9.94-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-31 23:55:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill 2013-07-01 14:14:19 EDT
Description of problem:
(note: I had to use windows to submit this bug,)
Background...
Most of the simplified Chinese (简体) digits have both a common, everyday, simple, easy to alter, easy to forge character and a more complicated, harder to alter, harder to forge character.  Examples:
0 零 零   (no difference in this case)
1 一 壹
2 二 贰
3 三 叁
4 四 泗
5 五 伍
6 六 陆
7 七 柒
8 八 捌
9 九 玖

The problem...
I can't find the more complicated 简体 character '陆' (6, pinyin spelling "liu" with a 4th tone) in ibus in Linux.


Version-Release number of selected component (if applicable):
I last updated my Fedora-18 system on Tuesday, June 25, 2013, and I always update everything.  So whatever version of ibus was current that evening, that's what I have.


How reproducible:


Steps to Reproduce:
1. Open a new file in a terminal window, LibreOffice, etc.
2. Activate ibus.
3. Enter "liu".  Look for the character '陆' in the ibus list (menu) of characters that match the pinyin "liu".

Actual results:
The character is not found.

Expected results:
The character should be found.

Additional info:
* I tried this in Gnome only.
* I tried this with simplified Chinese (简体) only, not traditional Chinese (繁体).
* The other formal simplified Chinese digits are available, only the one for 6 is missing.
* The common simplified Chinese digit for 6 ('六') is available.
Comment 1 Peng Wu 2013-07-08 03:52:23 EDT
Thanks for the report.

Please try to input "i 6" or "lu" to temporally work around this problem.

or try ibus-libpinyin to import "liu 陆" by yourself.

I will investigate it soon.
Comment 2 Fedora Update System 2013-10-29 00:38:27 EDT
libpinyin-0.9.94-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/libpinyin-0.9.94-1.fc20
Comment 3 Fedora Update System 2013-10-29 00:38:36 EDT
libpinyin-0.9.94-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/libpinyin-0.9.94-1.fc19
Comment 4 Fedora Update System 2013-10-29 14:05:43 EDT
Package libpinyin-0.9.94-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libpinyin-0.9.94-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-20220/libpinyin-0.9.94-1.fc20
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2013-10-31 23:55:57 EDT
libpinyin-0.9.94-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Bill 2013-11-01 21:27:58 EDT
I downloaded and tested the fix.  It works as it should.  Thank-you!
Comment 7 Fedora Update System 2013-11-10 01:55:36 EST
libpinyin-0.9.94-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.