Bug 980233 - bond as a member of a bridge and some other setups can not be handled completely
bond as a member of a bridge and some other setups can not be handled completely
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-node (Show other bugs)
3.2
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.3
Assigned To: Fabian Deutsch
node
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-01 15:25 EDT by Fabian Deutsch
Modified: 2013-11-11 04:59 EST (History)
12 users (show)

See Also:
Fixed In Version: ovirt-node-3.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-11 04:59:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 16505 None None None Never

  None (edit)
Description Fabian Deutsch 2013-07-01 15:25:01 EDT
Description of problem:
Due to the network rewrite many network setups are allowed, but some can still not be handled
e.g.:
* bond as a slave of a bridge
* tagged bond as a slave of a bridge
Comment 1 Fabian Deutsch 2013-07-04 10:49:28 EDT
The logic has been updated.

All supported layouts are now discovered.
The discovery is based on the central configuration file. So only if the configuration happened through Node the setup will be discovered and displayed correctly.

There is some best effort for other arbitrary setups.

Unittests were added which ensure that every setup we can create is also discovered correctly.
Comment 2 Sandro Bonazzola 2013-11-11 02:32:35 EST
oVirt gerrit 16505 is merged, can you set target release, fixed in version and move this to modified/on qa/closed accordingly?

Note You need to log in before you can comment on or make changes to this bug.