Bug 980241 - "Help" link in Horizon points to old (Folsom) docs
"Help" link in Horizon points to old (Folsom) docs
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon (Show other bugs)
3.0
Unspecified Unspecified
urgent Severity low
: async
: 3.0
Assigned To: Julie Pichon
Nir Magnezi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-01 16:00 EDT by Aaron Weitekamp
Modified: 2015-02-15 17:02 EST (History)
9 users (show)

See Also:
Fixed In Version: python-django-horizon-2013.1.2-2.el6ost
Doc Type: Bug Fix
Doc Text:
The "Help" link in the Dashboard (Horizon) directed users to the Red Hat OpenStack 2.0 (Folsom) documentation. The link has been updated to direct users to the Red Hat OpenStack 3.0 (Grizzly) documentation.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-10 11:42:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1020 normal SHIPPED_LIVE Red Hat OpenStack 3.0 bug fix advisory 2013-07-10 15:40:46 EDT

  None (edit)
Description Aaron Weitekamp 2013-07-01 16:00:15 EDT
Description of problem:
The "Help" link in Grizzly points to Folsom user guide v2.


Version-Release number of selected component (if applicable):
python-django-horizon-2013.1.2-1.el6ost.noarch


Steps to Reproduce:
1. Login to Horizon
2. Click "Help" link in upper-right corner


Actual results:
https://access.redhat.com/knowledge/docs/en-US/Red_Hat_OpenStack/2/html/Getting_Started_Guide/part-Using_OpenStack.html

Expected results:
https://access.redhat.com/knowledge/docs/en-US/Red_Hat_OpenStack/3/html/Getting_Started_Guide/part-Using_OpenStack.html
Comment 6 Nir Magnezi 2013-07-04 04:26:50 EDT
Tested NVR: python-django-horizon-2013.1.2-2.el6ost.noarch


Verification Steps:
===================
1. Login to Horizon
2. Click "Help" link in upper-right corner

Result:
=======
The following URL opened:
https://access.redhat.com/site/documentation/en-US/Red_Hat_OpenStack/3/html/Getting_Started_Guide/part-Using_OpenStack.html

Expected Result by Comment #0: 
https://access.redhat.com/knowledge/docs/en-US/Red_Hat_OpenStack/3/html/Getting_Started_Guide/part-Using_OpenStack.html

There is a small difference between the two -> the part after redhat.com/ (site vs knowledge) 

Should I count this as verified?
Comment 7 Julie Pichon 2013-07-04 04:48:23 EDT
There was a discussion on the review where Steve Gordon recommended using the /site/documentation/ URL directly (comment #2) as it is more stable, sorry for not updating the verification steps. (The /knowledge/docs/ URL actually redirects to /site/documentation/.)

Thanks!
Comment 9 Nir Magnezi 2013-07-07 02:16:12 EDT
(In reply to Julie Pichon from comment #7)
> There was a discussion on the review where Steve Gordon recommended using
> the /site/documentation/ URL directly (comment #2) as it is more stable,
> sorry for not updating the verification steps. (The /knowledge/docs/ URL
> actually redirects to /site/documentation/.)
> 
> Thanks!

Thanks Juile.
Marking as Verified.
Comment 10 errata-xmlrpc 2013-07-10 11:42:36 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1020.html

Note You need to log in before you can comment on or make changes to this bug.