Bug 980321 - Scaled up gear is in down status for jboss related apps if without git push
Scaled up gear is in down status for jboss related apps if without git push
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Dan Mace
libra bugs
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-02 01:03 EDT by Meng Bo
Modified: 2015-05-14 19:22 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-22 11:19:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Meng Bo 2013-07-02 01:03:02 EDT
Description of problem:
Create a scalable jboss app, scale-up the app, go to haproxy-status page to check the gear status, we can find the scaled-up web gear is down.

If scaled up to 3 gears or set min gear to 3, the local gear will become down even if the other gears have not been started.

After some change and git push, the gear will be up.


And from the rhc client, we can get the gears are all started.
$ rhc app show jbeap1s --gears
ID                       State   Cartridges               Size  SSH URL
------------------------ ------- ------------------------ ----- --------------------------------------------------------------------------
51d2542a2587c8f2f1000077 started jbosseap-6.0 haproxy-1.4 small 51d2542a2587c8f2f1000077@jbeap1s-bmengstg.stg.rhcloud.com
51d254a32587c8f2f100009b started jbosseap-6.0 haproxy-1.4 small 51d254a32587c8f2f100009b@51d254a32587c8f2f100009b-bmengstg.stg.rhcloud.com

Version-Release number of selected component (if applicable):
STG (devenv-stage_383)
devenv_3434

How reproducible:
always

Steps to Reproduce:
1.Create any scalable jboss app 
2.Manual scale-up or set the min gear greater than 1 via rhc client
3.Go to haproxy-status page to check the gear status

Actual results:
The new scaled-up gear is in a down status.

Expected results:
Gears should be up after added.

Additional info:
This issue happens for current STAGE.

Access the gear home page via browser will get a blank page.
Comment 1 Meng Bo 2013-07-02 01:59:29 EDT
Reduce the severity to medium. 
Since a git push no matter before scale-up or after scale-up will avoid this problem.
Comment 2 Mrunal Patel 2013-07-09 14:42:43 EDT
There is some issue with jboss deployment on scale up. The secondary gear jboss returns 404. The behavior of local gear is correct since it waits for some time and then goes down.
Comment 3 Mrunal Patel 2013-07-09 19:34:23 EDT
./jbossas/standalone/deployments/ROOT.war file is missing on the secondary gear.
Comment 4 Dan Mace 2013-07-10 13:43:02 EDT
This issue affects initial scale-up events for jbossas, jbosseap, and jbossews due to a prior change which results in the initial ROOT.war being present only in the live deployments directory and not $OPENSHIFT_REPO_DIR.
Comment 6 openshift-github-bot 2013-07-10 16:54:08 EDT
Commit pushed to master at https://github.com/openshift/origin-server

https://github.com/openshift/origin-server/commit/d7954c22b3e7deaa2747d6d7815beac888b1bac1
Bug 980321: Sync repo dir with live deployments dir on initial install
Comment 7 Meng Bo 2013-07-11 04:05:04 EDT
Checked on devenv_3482, issue has been fixed.

Jboss app scale-up gear in up status after scaled up.

And the ROOT.war exist for all gears.

$rhc ssh jbas1s --gears "ls app-root/repo/deployments/" 
[51de63c036ff800a00000009 jbossas-7+haproxy-1.4] ROOT.war
[23783c5ce9fd11e29af122000a8a0ade jbossas-7+haproxy-1.4] ROOT.war
[51de63c036ff800a0000000a jbossas-7+haproxy-1.4] ROOT.war

Note You need to log in before you can comment on or make changes to this bug.