Bug 980346 - [RFE] As a project maintainer I want contextual help when choosing a project type.
[RFE] As a project maintainer I want contextual help when choosing a project ...
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Component-UI (Show other bugs)
3.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Mason
Damian Jansen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-02 02:36 EDT by David Mason
Modified: 2013-11-26 22:31 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-26 22:31:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Mason 2013-07-02 02:36:42 EDT
Description of problem:
Project types may be confusing to maintainers. Confusion can be reduced and discoverability improved by adding some information inline where project type is selected.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Sign in and begin to create a project
2. Try to find information about what different project types mean.

Actual results:
Have to go to a wiki page to read about project types.

Expected results:
Some information is visible inline that can help choose an appropriate project type without navigation.
Comment 1 David Mason 2013-07-10 01:57:56 EDT
Added descriptions in project type selectors for create/edit project and create/edit version.

See: https://github.com/zanata/zanata-server/commit/28816a25f3b275d4941e974c50bf29265e1dfded
Comment 2 Damian Jansen 2013-07-21 20:44:49 EDT
Looks good, much more descriptive.
I'd like to see Gettext being at the top of the list (986732) and the link in the help bubble clickable (the latter probably not achievable due to the nature of help bubbles) - but I'm just being picky.
Comment 3 David Mason 2013-07-21 21:20:24 EDT
(In reply to Damian Jansen from comment #2)
> Looks good, much more descriptive.
> I'd like to see Gettext being at the top of the list (986732) and the link
> in the help bubble clickable (the latter probably not achievable due to the
> nature of help bubbles) - but I'm just being picky.

I think a clickable link in the help bubble is possible, just not supported by the framework, which means we need to use a better framework or figure out how to work around it.
Comment 4 Sean Flanigan 2013-11-26 22:31:30 EST
Closing VERIFIED bugs which predate Zanata 3.1.2.

Note You need to log in before you can comment on or make changes to this bug.