Bug 980357 - [RFE] Check for "Press (any key|enter) to continue" when systems fail to boot
[RFE] Check for "Press (any key|enter) to continue" when systems fail to boot
Status: CLOSED DUPLICATE of bug 952661
Product: Beaker
Classification: Community
Component: lab controller (Show other bugs)
0.13
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ---
: ---
Assigned To: beaker-dev-list
tools-bugs
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-02 03:25 EDT by Nick Coghlan
Modified: 2014-08-12 00:32 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-22 18:05:12 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nick Coghlan 2013-07-02 03:25:01 EDT
If a system has a hardware problem that causes it to emit a "Press any key to continue" message during boot, this will show up in Beaker as a string of aborted jobs. If those jobs aren't using appropriately marked distros (see bug 654299), then the system won't be automatically marked as broken.

This proposal is to add a new heuristic for automatically marking systems as broken:

1. The recipe is terminated by the external watchdog
2. The system doesn't reboot at all (install_start is never called on the lab controller)
3. The console log contains an entry matching one of the patterns:
"Press any key to continue"
"Press [Ee]nter to continue"
"Press <(.*)> to continue"

Such a heuristic could also be tweaked to detect the PXE boot menu coming up (indicating the machine isn't properly booting from the network).

This should be configurable in a similar fashion to the PANIC_REGEX definition (BOOT_HANG_REGEX, perhaps?).
Comment 1 Nick Coghlan 2013-09-02 23:49:33 EDT
Anaconda may also hang with its text UI displayed to ask a question. This shows up in the console log as an ASCII-art display window, containing at least an ASCII art "OK" box and a bottom row of instructions indicating how to navigate the controls with the keyboard.
Comment 2 Dan Callaghan 2014-01-22 18:05:12 EST

*** This bug has been marked as a duplicate of bug 952661 ***

Note You need to log in before you can comment on or make changes to this bug.