Bug 980373 - Cookie forces default JBoss cartridge webpage to be displayed instead of Application homepage
Cookie forces default JBoss cartridge webpage to be displayed instead of Appl...
Status: CLOSED WORKSFORME
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
1.x
Unspecified Unspecified
medium Severity high
: ---
: ---
Assigned To: Dan Mace
libra bugs
: SupportQuestion
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-02 04:00 EDT by Paul McKeown
Modified: 2013-07-29 16:34 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-29 16:34:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul McKeown 2013-07-02 04:00:32 EDT
When I navigate to my domain: http://theowl.co I get the "Welcome to OpenShift, JBossAS7 Cartridge" default JBoss page, even though the application is running. This happens in Firefox and Safari, though when I navigate to the same URL in Chrome, I get my homepage.

Using Firebug, I deleted all cookies for the site and refreshed, and then I got my apps homepage. I narrowed down the cookies that were being generated by something in my Openshift stack to a single one that is causing the issue: GEAR.

Once this GEAR cookie has been deleted I can access my website properly.

The content of the GEAR cookie is: 51c4f98b4382ecfb62000053-pmckeown

The issue also occurs when i navigate to my RH domain http://theowl-pmckeown.rhcloud.com/

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Navigate to http://theowl-pmckeown.rhcloud.com/ in Firefox
2. Confirm "Welcome to Openshift" page
3. Use firebug or equivalent to delete the GEAR cookie
4. Refresh the page
5. Confirm my application homepage is displayed
Comment 1 Paul McKeown 2013-07-06 20:49:19 EDT
Hey, I reverted a setting in my Openshift admin console which I believe has resolved the issue.

Under the 'Scale your application' page, I had recently changed the minimum number of small gears to 2 for my JBoss Application Server 7 cartridge.  Restoring this back to a minimum of 1 gear and a maximum of all available seems to have stopped the problem from manifesting.  Though there does seem to still be an issue with this scaling of this cartridge.
Comment 2 Dan Mace 2013-07-29 16:34:22 EDT
Going to close this one; I couldn't reproduce with a new scaled application, and the user reports that theirs is now working. If the problem happens again, we'll need a broken application to analyze.

Note You need to log in before you can comment on or make changes to this bug.