Bug 980400 - spice-gtk should require glib >= 2.26
spice-gtk should require glib >= 2.26
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: spice-gtk (Show other bugs)
Unspecified Unspecified
high Severity urgent
: rc
: ---
Assigned To: Christophe Fergeau
Desktop QE
: TestBlocker
Depends On:
  Show dependency treegraph
Reported: 2013-07-02 05:35 EDT by Christophe Fergeau
Modified: 2013-11-21 03:27 EST (History)
11 users (show)

See Also:
Fixed In Version: spice-gtk-0.20-3.el6
Doc Type: Bug Fix
Doc Text:
Cause: Now that spice-gtk is built against newer gtk+/glib versions, it has a runtime dependency on these versions Consequence: Upgrading spice-gtk without upgrading gtk+/glib at the same time would cause application using spice-gtk to crash at startup Fix: Adjust the RPM dependencies so that spice-gtk RPMs require new enough versions of gtk+/glib Result: spice-gtk cannot be installed unless the gtk+/glib versions it needs are installed as well.
Story Points: ---
Clone Of: 980344
Last Closed: 2013-11-21 03:27:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Comment 3 Marc-Andre Lureau 2013-07-02 09:14:31 EDT
I am not sure we need to explicitely bump the requirement in the spec. Those bugs quite clearly indicate that the update or the compose is not in sync with the build environment. It's not really the spec fault.
Comment 4 Christophe Fergeau 2013-07-02 09:44:31 EDT
Adding an explicit requirement is easy (if glib used symbol versioning it would even be done automatically), and this avoids confusion if people try to cherry-pick just a few updated packages, so I'd be in favour of having these version bumps as this potentially avoid more bug reports like this one.
Comment 6 CongDong 2013-07-29 21:50:40 EDT
I tried with the virt-viewer-0.5.6-5.el6.
If I didn't update the glib2, the error message when I install virt-viewer is:

Error: Package: virt-viewer-0.5.6-6.el6.x86_64 (/virt-viewer-0.5.6-6.el6.x86_64)
           Requires: gtk2 >= 2.20
           Installed: gtk2-2.18.9-12.el6.x86_64 (@anaconda-RedHatEnterpriseLinux-201301301459.x86_64/6.4)
               gtk2 = 2.18.9-12.el6
Error: Package: virt-viewer-0.5.6-6.el6.x86_64 (/virt-viewer-0.5.6-6.el6.x86_64)
           Requires: glib2 >= 2.26
           Installed: glib2-2.22.5-7.el6.x86_64 (@anaconda-RedHatEnterpriseLinux-201301301459.x86_64/6.4)
               glib2 = 2.22.5-7.el6
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

As the result, set VERIFIED
Comment 8 errata-xmlrpc 2013-11-21 03:27:27 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.