Bug 980406 - db-control: backup -- backup-log.dat contains full (not relative) paths
db-control: backup -- backup-log.dat contains full (not relative) paths
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
unspecified
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Jan Dobes
Matej Kollar
:
Depends On:
Blocks: 819032 sat560-lowbug
  Show dependency treegraph
 
Reported: 2013-07-02 05:51 EDT by Matej Kollar
Modified: 2013-10-01 17:55 EDT (History)
3 users (show)

See Also:
Fixed In Version: spacewalk-web-2.0.3-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 17:55:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matej Kollar 2013-07-02 05:51:57 EDT
Description of problem:

  Creating backup with full path as parameter leads to full
  paths in log (which may cause trouble when things are moved around).

Version-Release number of selected component: spacewalk-dobby-1.9.22-17.el5sat

How reproducible: always/deterministic


Steps to Reproduce:
1. mkdir /tmp/backup; chmod a+w /tmp/backup # or whatever to make it writable...
2. db-control backup /tmp/backup
3. observe /tmp/backup/backup-log.dat, backuplog.coldfiles.fileentry.to

Actual results: file contains absolute paths

Expected results: file contains paths relative to backup dir
Comment 1 Jan Dobes 2013-07-16 05:12:55 EDT
fixed in spacewalk master, commit: f32040f8d9d4f9cfcdf3919f0e1b588aa53aa5f3
Comment 6 Clifford Perry 2013-10-01 17:55:13 EDT
Satellite 5.6 has been released. This bug was tracked under the release.  

This bug was either VERIFIED or RELEASE_PENDING (re-verified prior shortly
before release). 

Moving to CLOSED CURRENT_RELEASE. 

Text from Upgrade Erratum follows:

Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1395.html

Note You need to log in before you can comment on or make changes to this bug.