Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 980438 - exceptionname is indented as a block element
Summary: exceptionname is indented as a block element
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: PressGang CCMS
Classification: Community
Component: Web-UI
Version: 1.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Lee Newson
QA Contact: Douglas Silas
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-02 11:26 UTC by Eva Kopalova
Modified: 2016-06-17 21:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-09-30 23:36:45 UTC


Attachments (Terms of Use)

Description Eva Kopalova 2013-07-02 11:26:44 UTC
Description of problem:
exceptionname is indented as a block element


Steps to Reproduce:
1. use the exceptionname docbook tag in the browser xml editor (inline):
		<para>
			The rules are evaluated at the moment the fact is inserted. Therefore, if you are using a Global to constraint a fact pattern, and the global is not set, the system returns a 
			<exceptionname>NullPointerException</exceptionname>.
		</para>
2. save..watch the text being re-indented:

		<para>
			The rules are evaluated at the moment the fact is inserted. Therefore, if you are using a Global to constraint a fact pattern, and the global is not set, the system returns a 
			<exceptionname>
				NullPointerException
			</exceptionname>.
		</para>
3. watch the new rendering (as it is rendered as code, the use of spaces is incorrect 

Actual results:
This particular example results in the following rendering:
...the system returns a  NullPointerException .

Expected results:
The following rendering:
...the system returns a NullPointerException.

Additional info:
is it possible to provide a pure text entry field? (this would allow us to workaround such issues in the editor if necessary)

Comment 1 Lee Newson 2013-07-02 22:13:52 UTC
In future, can you please either use the "Create Bug" link in the UI, or include the Build number so we are aware what version this is being logged against.

Anyway this has now been fixed and any current incorrect formatting has also been patched.

Comment 4 Lee Newson 2013-09-30 23:36:45 UTC
I'm going to close this, since Eva is no longer with Red Hat. If it doesn't work than please re-open the bug.


Note You need to log in before you can comment on or make changes to this bug.