Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 980441 - Stale glustershd and gluster nfs processes after peer detach.
Summary: Stale glustershd and gluster nfs processes after peer detach.
Keywords:
Status: CLOSED DUPLICATE of bug 980440
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd
Version: 2.1
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
: ---
Assignee: Amar Tumballi
QA Contact: Sudhir D
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-02 11:29 UTC by M S Vishwanath Bhat
Modified: 2016-06-01 01:56 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-07-02 11:31:27 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description M S Vishwanath Bhat 2013-07-02 11:29:04 UTC
Description of problem:
After a peer detach stale glustershd and gluster nfs processes will be running. There were no volume information in /var/lib/glusterd/vols and /var/lib/glusterd/peers. But /var/lib/glusterd/nfs had some stale data.

Ideally all these should be cleaned up and the processes should be exited gracefully when we did peer detach.


Version-Release number of selected component (if applicable):
glusterfs 3.4.0.12rhs.beta1

How reproducible:
1/1

Steps to Reproduce:
1. Created a cluster of 4 nodes.
2. Created a pure replicate volume of replica count 2. So only two peers host the bricks and other 2 peers don't have any bricks. And the glustershd and gluster nfs processes will be running in those other two peers where there is no glusterfsd.
3. Now since those two bricks doesn't have nay bricks do peer detach on them
4. Check the /var/lib/glusterd/{vols,peers,nfs}

Actual results:
glustershd and gnfs processes are still running. Some stale data present in the /var/lib/glusterd/nfs

Expected results:
There should be no stale data in glusterd store and there should be no stale processes running.

Additional info:

Comment 1 M S Vishwanath Bhat 2013-07-02 11:31:27 UTC
Somehow it's submitted twice creating two entries in BZ for single bug. https://bugzilla.redhat.com/show_bug.cgi?id=980440

*** This bug has been marked as a duplicate of bug 980440 ***


Note You need to log in before you can comment on or make changes to this bug.