Bug 980465 - The status of nic was shown "unconfigured" when configure nic with "static ipv4"
The status of nic was shown "unconfigured" when configure nic with "static ipv4"
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.5
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Fabian Deutsch
Virtualization Bugs
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-02 08:58 EDT by haiyang,dong
Modified: 2014-01-21 14:43 EST (History)
13 users (show)

See Also:
Fixed In Version: ovirt-node-3.0.0-6.el6
Doc Type: Bug Fix
Doc Text:
Previously a NIC was only assumed to be configured if a bootprotocol was given. But this is wrong for the static IP cases when no bootprotocol but an IP address are set. The symptoms were that the NIC appeared as unconfigured in the network page, when a static IP was set.The logic has been updated and a NIC is assumed to be configured when a bootprotocol or an IP address is set, so the NIC appears as configured in the network page.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 14:43:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
attached Screenshot for network page (63.62 KB, image/png)
2013-07-02 08:58 EDT, haiyang,dong
no flags Details
attached Screenshot for nic detail page (54.99 KB, image/png)
2013-07-02 08:59 EDT, haiyang,dong
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 16507 None None None Never
Red Hat Product Errata RHBA-2014:0033 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update 2014-01-21 19:14:30 EST

  None (edit)
Description haiyang,dong 2013-07-02 08:58:45 EDT
Created attachment 767720 [details]
attached Screenshot for network page

Description of problem:
Configure nic with "static ipv4", after configured nic successfully, check that
the status of nic was shown "unconfigured" in network page(seen nework_page.png) and Bootprotocol was
shown "Disabled" in network detail page(seen nic detail page.png).


Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.5-20130222.0.auto1707.el6.iso
ovirt-node-3.0.0-1.999.20130701111251git99aadc6.el6.noarch

How reproducible:
100%

Steps to Reproduce:


Actual result:

                                                           
Expect result:

Additional info:
Comment 1 haiyang,dong 2013-07-02 08:59:36 EDT
Created attachment 767721 [details]
attached Screenshot for nic detail page
Comment 4 Fabian Deutsch 2013-07-05 07:15:49 EDT
Fixed in gerrit patch.

Tested as follows:
1. Patched UI
2. Configure NIC with static IP
3. Enter Network page
NIC appears as configured
Comment 6 haiyang,dong 2013-08-01 22:13:42 EDT
Test version:
rhev-hypervisor6-6.5-20130725.0.el6 
ovirt-node-3.0.0-6.1.el6

Tested as follows:
1. Clean install rhev-hypervisor6-6.5-20130725.0.el6 
2. Configure NIC with static IPv4
3. Enter Network page
NIC appears as configured and also the Bootprotocol of "IPv4 Setting" was
shown "(X) Static" in network detail page

so this bug has been fixed, change the status into "VERIFIED"
Comment 7 haiyang,dong 2013-08-02 02:01:45 EDT
Need add Keywords "Regression" into this bug for it's a regression bug from rhev-h 6.4.z to rhev-h 6.5
Comment 12 Cheryn Tan 2013-11-07 19:33:08 EST
This bug is currently attached to errata RHBA-2013:15277. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 14 errata-xmlrpc 2014-01-21 14:43:15 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0033.html

Note You need to log in before you can comment on or make changes to this bug.