Bug 980477 - ovirt-firstboot may wipe RHEV Storage Domain if kernel changes device order
ovirt-firstboot may wipe RHEV Storage Domain if kernel changes device order
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.4
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: Mike Burns
Virtualization Bugs
: ZStream
Depends On: 889071
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-02 09:54 EDT by Idith Tal-Kohen
Modified: 2016-04-26 12:12 EDT (History)
22 users (show)

See Also:
Fixed In Version: ovirt-node-2.5.0-17.el6_4.8
Doc Type: Bug Fix
Doc Text:
The kernel ordering of /dev/sdX devices is not necessarily deterministic. When booting the Hypervisor using PXE with the storage_init parameter set to a /dev/sdX device it was therefore possible to accidentally delete data from Red Hat Enterprise Virtualization storage domains. Additional safe guards have been added to check that the device specified in the storage_init parameter does not contain a storage domain. Installation is blocked where this is the case. To use the storage_init parameter in a deterministic manner specify devices using the paths presented under /dev/mapper/ instead of paths of the form /dev/sdX.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-16 11:29:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Idith Tal-Kohen 2013-07-02 09:54:31 EDT
This bug has been copied from bug #889071 and has been proposed
to be backported to 6.4 z-stream (EUS).
Comment 16 Ying Cui 2013-07-10 04:50:46 EDT
The bug status is MODIFIED, after devel change it to 'ON-QA', we will change it to 'verified' according to comment 15.
Comment 17 Ying Cui 2013-07-15 08:02:30 EDT
Change it to 'Verified' according to comment 15.
Comment 19 errata-xmlrpc 2013-07-16 11:29:40 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1077.html

Note You need to log in before you can comment on or make changes to this bug.