Bug 980481 - Rotate /var/log/messages on rhev-h.
Rotate /var/log/messages on rhev-h.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.5
Unspecified Unspecified
urgent Severity high
: rc
: ---
Assigned To: Mike Burns
Virtualization Bugs
: ZStream
Depends On: 975518
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-02 09:58 EDT by Idith Tal-Kohen
Modified: 2013-11-27 19:08 EST (History)
19 users (show)

See Also:
Fixed In Version: ovirt-node-2.5.0-17.el6_4.6
Doc Type: Bug Fix
Doc Text:
The log rotation configuration stored in the /etc/logrotate.d/syslog file was not correctly set up to rotate the /var/log/messages file. As a result the /var/log/messages file was deleted instead of rotated when the log rotation cron job ran. The /etc/logrotate.d/syslog file has been updated to correctly configure log rotation for the /var/log/messages file.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-16 11:30:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Idith Tal-Kohen 2013-07-02 09:58:25 EDT
This bug has been copied from bug #975518 and has been proposed
to be backported to 6.4 z-stream (EUS).
Comment 5 wanghui 2013-07-03 04:38:36 EDT
This bug has been fixed in ovirt-node-2.5.0-17.el6_4.6.noarch(rhev-hypervisor6-6.4-20130702.0.el6_4.noarch.rpm).

Test steps:
1. Clean install rhev-hypervisor6-6.4-20130702.0.el6_4.
2. Check the /etc/cron.d/ovirt-logrotate file and the output as follows.
   */10 * * * * root /usr/sbin/logrotate /etc/logrotate.conf
3. Run for a while.
4. Change the system date to one week later.
5. Reboot the host.
6. Check in /var/log.

Results:
After step6, there is another rotated messages file in /var/log.

So the bug is fixed in this build. Change the status from ON_QA to VERIFIED.
Comment 7 errata-xmlrpc 2013-07-16 11:30:04 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1077.html

Note You need to log in before you can comment on or make changes to this bug.