Bug 980491 - Installation of openshift-origin-cartridge-python fails
Installation of openshift-origin-cartridge-python fails
Status: CLOSED WORKSFORME
Product: OpenShift Origin
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Krishna Raman
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-02 10:09 EDT by Jan Pazdziora
Modified: 2015-05-14 19:12 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-21 14:28:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Pazdziora 2013-07-02 10:09:24 EDT
Description of problem:

I did an all-on-one Origin installation of https://mirror.openshift.com/pub/origin-server/nightly/fedora-19/latest/x86_64/ (which seems to point to 2013-07-01) using the puppet way and there were errors installing the openshift-origin-cartridge-python cartridge.

Version-Release number of selected component (if applicable):

Origin nightly compose 2013-07-01 on Fedora 19.

How reproducible:

Seen once, suspect it to be deterministic.

Steps to Reproduce:
1. Run puppet apply --verbose configure_origin.pp

Actual results:

[0;32mInfo: /Stage[main]/Openshift_origin::Node/Package[openshift-origin-cartridge-mock]: Scheduling refresh of Exec[oo-admin-cartridge][0m
[1;31mError: Execution of '/usr/bin/yum -d 0 -e 0 -y install openshift-origin-cartridge-python' returned 1: Package pymongo is obsoleted by python-pymongo, but obsoleting package does not provide for requirements
Package pymongo is obsoleted by python-pymongo, but obsoleting package does not provide for requirements
Package pymongo is obsoleted by python-pymongo, but obsoleting package does not provide for requirements
Package pymongo is obsoleted by python-pymongo, but obsoleting package does not provide for requirements
Package pymongo is obsoleted by python-pymongo, but obsoleting package does not provide for requirements
Error: Package: pymongo-gridfs-2.1.1-3.fc19.x86_64 (beaker-Fedora)
           Requires: pymongo = 2.1.1-3.fc19
           Available: pymongo-2.1.1-3.fc19.x86_64 (beaker-Fedora)
               pymongo = 2.1.1-3.fc19
           Available: python-pymongo-2.5-4.fc19.x86_64 (fedora)
               pymongo = 2.5-4.fc19
           Installing: python-pymongo-2.5.2-1.fc19.x86_64 (updates)
               pymongo = 2.5.2-1.fc19
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
[0m
[1;31mError: /Stage[main]/Openshift_origin::Node/Package[openshift-origin-cartridge-python]/ensure: change from absent to present failed: Execution of '/usr/bin/yum -d 0 -e 0 -y install openshift-origin-cartridge-python' returned 1: Package pymongo is obsoleted by python-pymongo, but obsoleting package does not provide for requirements
Package pymongo is obsoleted by python-pymongo, but obsoleting package does not provide for requirements
Package pymongo is obsoleted by python-pymongo, but obsoleting package does not provide for requirements
Package pymongo is obsoleted by python-pymongo, but obsoleting package does not provide for requirements
Package pymongo is obsoleted by python-pymongo, but obsoleting package does not provide for requirements
Error: Package: pymongo-gridfs-2.1.1-3.fc19.x86_64 (beaker-Fedora)
           Requires: pymongo = 2.1.1-3.fc19
           Available: pymongo-2.1.1-3.fc19.x86_64 (beaker-Fedora)
               pymongo = 2.1.1-3.fc19
           Available: python-pymongo-2.5-4.fc19.x86_64 (fedora)
               pymongo = 2.5-4.fc19
           Installing: python-pymongo-2.5.2-1.fc19.x86_64 (updates)
               pymongo = 2.5.2-1.fc19
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
[0m
[mNotice: /File[plugin openshift-origin-dns-nsupdate.conf]/ensure: defined content as '{md5}edbe64ac37c943051b25fdd85b3fcf4b'[0m

Expected results:

No errors.

Additional info:
Comment 2 Jan Pazdziora 2013-07-15 04:43:37 EDT
I no longer experience the problem todya with

https://mirror.openshift.com/pub/origin-server/nightly/fedora-19/2013-07-14/x86_64/
Comment 3 Krishna Raman 2013-08-21 14:28:19 EDT
Should be working now with both with release 2 and master branches

Note You need to log in before you can comment on or make changes to this bug.