Bug 980495 - AVC denial for squid passive ftp
AVC denial for squid passive ftp
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: selinux-policy (Show other bugs)
5.10
All Linux
low Severity low
: rc
: ---
Assigned To: Miroslav Grepl
Milos Malik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-02 10:14 EDT by Karel Srot
Modified: 2013-09-30 18:26 EDT (History)
2 users (show)

See Also:
Fixed In Version: selinux-policy-2.4.6-345.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-30 18:26:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karel Srot 2013-07-02 10:14:05 EDT
Description of problem:

time->Sun Jun 30 20:49:03 2013
type=SYSCALL msg=audit(1372639743.841:150): arch=c000003e syscall=42 success=no exit=-13 a0=10 a1=1b3fab54 a2=10 a3=1b40e1c0 items=0 ppid=13952 pid=13954 auid=4294967295 uid=23 gid=23 euid=23 suid=0 fsuid=23 egid=23 sgid=23 fsgid=23 tty=(none) ses=4294967295 comm="squid" exe="/usr/sbin/squid" subj=root:system_r:squid_t:s0 key=(null)
type=AVC msg=audit(1372639743.841:150): avc:  denied  { name_connect } for  pid=13954 comm="squid" dest=48875 scontext=root:system_r:squid_t:s0 tcontext=system_u:object_r:port_t:s0 tclass=tcp_socket


appears when squid is configured for passive ftp access

on RHEL-6 we have:

ET allow squid_t port_type : tcp_socket { name_bind name_connect } ; [ squid_connect_any ]


Version-Release number of selected component (if applicable):
selinux-policy-2.4.6-338.el5

How reproducible:
always

Steps to Reproduce:
echo 'pasv_enable=YES' >> $VSFTPD_CONF
echo 'ftp_passive on' >> $SQUID_CONF
service vsftpd restart
service squid restart
ftp_proxy=http://127.0.0.1:3128 wget ftp://127.0.0.1/pub/ftp-proxy-test
Comment 3 RHEL Product and Program Management 2013-07-03 10:37:55 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 7 errata-xmlrpc 2013-09-30 18:26:03 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1312.html

Note You need to log in before you can comment on or make changes to this bug.