Bug 980526 - mongoid requires moped 1.4.2, but 1.5 is in Fedora
mongoid requires moped 1.4.2, but 1.5 is in Fedora
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rubygem-mongoid (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Troy Dawson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-02 11:46 EDT by Troy Dawson
Modified: 2013-07-11 23:08 EDT (History)
1 user (show)

See Also:
Fixed In Version: rubygem-mongoid-3.1.4-1.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-10 22:31:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Troy Dawson 2013-07-02 11:46:05 EDT
Description of problem:
The gemspec in rubygem-mongoid

Version-Release number of selected component (if applicable):
rubygem-mongoid-3.1.3-1

How reproducible:
100%

Steps to Reproduce:
1. Install rubygem-mongoid
2. irb
3. > require 'mongoid'

Actual results:
Gem::LoadError: Could not find 'moped' (~> 1.4.2) - did find: [moped-1.5.0]
	from /usr/share/rubygems/rubygems/dependency.rb:296:in `to_specs'
	from /usr/share/rubygems/rubygems/specification.rb:1196:in `block in activate_dependencies'
	from /usr/share/rubygems/rubygems/specification.rb:1185:in `each'
	from /usr/share/rubygems/rubygems/specification.rb:1185:in `activate_dependencies'
	from /usr/share/rubygems/rubygems/specification.rb:1167:in `activate'
	from /usr/share/rubygems/rubygems.rb:181:in `rescue in try_activate'
	from /usr/share/rubygems/rubygems.rb:178:in `try_activate'
	from /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:109:in `rescue in require'
	from /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:35:in `require'
	from (irb):1
	from /usr/bin/irb:12:in `<main>'


Expected results:
=> true

Additional info:
The only place that the version of moped is listed is in /usr/share/gems/specifications/mongoid-3.1.3.gemspec  Everything else in the package is version independant.
Comment 1 Fedora Update System 2013-07-02 13:11:04 EDT
rubygem-mongoid-3.1.4-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/rubygem-mongoid-3.1.4-1.fc18
Comment 2 Fedora Update System 2013-07-02 13:12:06 EDT
rubygem-mongoid-3.1.4-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/rubygem-mongoid-3.1.4-1.fc19
Comment 3 Fedora Update System 2013-07-02 23:31:34 EDT
Package rubygem-mongoid-3.1.4-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing rubygem-mongoid-3.1.4-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-12219/rubygem-mongoid-3.1.4-1.fc19
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2013-07-10 22:31:36 EDT
rubygem-mongoid-3.1.4-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Fedora Update System 2013-07-11 23:08:48 EDT
rubygem-mongoid-3.1.4-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.