Bug 98061 - Bad Blocks detected causes Install to halt
Bad Blocks detected causes Install to halt
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-25 17:47 EDT by Matt Perry
Modified: 2007-04-18 12:55 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-26 11:59:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Perry 2003-06-25 17:47:51 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3) Gecko/20030312

Description of problem:
This is similiar to Bugs numbered 89174 and 87947.  These are closed.  And
unfortunately, the solution giving was don't check for bad blocks and they are
going to remove this option in later versions.  But this option works fine in
7.3 and 8.0 on the same system, so something was changed in 9.0 (see #2)  Please
don't remove this option in later releases!

I would have just re-opened them, but here is why i prefer making a new bug.

1. Tech support technician suggested
2. This problem DOES NOT EXIST in 7.3, or 8.0!  I've reformatted this machine
probably 15 times with different versions of redhat, different configurations,
etc., including taking certian hard disks out, only installing with one, etc.
3. Only occurs if you have more then one hard disk, and you check for bad blocks
on at least 2 of them.  If you have 3 hard disks, but only put partitions on one
disk, you can check for bad blocks and it installs fine.  


Please, don't take the bad blocks check out of the new release, and please put
the option to use fdisk back in anaconda like in 8.0.  :)
8.0 seemed to work fine for this part.  :)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install 9.0 on a multidisk system
2. Run bad block check on at least 2 disks
3.
    

Actual Results:  Detects bad blocks, requires a reboot, will not finish install.
 But bad blocks are not detected if you install withouth checking and check
later, AND bad blocks are not detected with a Redhat 7.3 or 8.0 install.

Expected Results:  if there are bad blocks, let us now.  If not, finish the install.

Additional info:

Please don't remove this option. And it would be nice if you could put back the
fdisk option that was in 8.0.

Thanks.
Comment 1 Michael Fulbright 2003-06-26 11:59:15 EDT
The fdisk and badblocks options were removing because they were determined to be
not necessary (lack of overall customer interest) and because we have disk druid
and parted. fdisk is still available on VC2 if you need it.  However if there is
a bug in disk druid or parted that prevents you from using them please report it
so we can make them work in that case.

Note You need to log in before you can comment on or make changes to this bug.