Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 980623 - SELinux is preventing /usr/bin/convert from 'create' accesses on the file magickMVm8lp.
Summary: SELinux is preventing /usr/bin/convert from 'create' accesses on the file mag...
Keywords:
Status: CLOSED DUPLICATE of bug 825874
Alias: None
Product: Fedora
Classification: Fedora
Component: ImageMagick
Version: 19
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Pavel Alexeev
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:b9a4ddddfc6e39bd72aa8fc9686...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-02 21:07 UTC by Yajo
Modified: 2013-07-14 19:16 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-07-14 19:16:24 UTC
Type: ---


Attachments (Terms of Use)

Description Yajo 2013-07-02 21:07:39 UTC
Description of problem:
SELinux is preventing /usr/bin/convert from 'create' accesses on the file magickMVm8lp.

*****  Plugin catchall (100. confidence) suggests  ***************************

If cree que de manera predeterminada, convert debería permitir acceso create sobre  magickMVm8lp file.     
Then debería reportar esto como un error.
Puede generar un módulo de política local para permitir este acceso.
Do
permita el acceso momentáneamente executando:
# grep convert /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023
Target Context                unconfined_u:object_r:user_home_t:s0
Target Objects                magickMVm8lp [ file ]
Source                        convert
Source Path                   /usr/bin/convert
Port                          <Desconocido>
Host                          (removed)
Source RPM Packages           ImageMagick-6.7.8.9-5.fc19.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-54.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.9.8-300.fc19.x86_64 #1 SMP Thu
                              Jun 27 19:24:23 UTC 2013 x86_64 x86_64
Alert Count                   7
First Seen                    2013-07-02 23:05:05 CEST
Last Seen                     2013-07-02 23:05:14 CEST
Local ID                      a8ee0ca1-f36d-4178-937f-00a2d90a8369

Raw Audit Messages
type=AVC msg=audit(1372799114.941:449): avc:  denied  { create } for  pid=5101 comm="convert" name="magickMVm8lp" scontext=unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_home_t:s0 tclass=file


type=SYSCALL msg=audit(1372799114.941:449): arch=x86_64 syscall=open success=no exit=EACCES a0=148c2d0 a1=c2 a2=180 a3=0 items=0 ppid=5087 pid=5101 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 ses=1 tty=(none) comm=convert exe=/usr/bin/convert subj=unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023 key=(null)

Hash: convert,thumb_t,user_home_t,file,create

Additional info:
reporter:       libreport-2.1.5
hashmarkername: setroubleshoot
kernel:         3.9.8-300.fc19.x86_64
type:           libreport

Comment 1 Garve 2013-07-03 00:16:21 UTC
Description of problem:
Browsing /boot/grub2/themes.

Additional info:
reporter:       libreport-2.1.5
hashmarkername: setroubleshoot
kernel:         3.9.8-300.fc19.x86_64
type:           libreport

Comment 2 Miroslav Grepl 2013-07-03 12:54:47 UTC
Where is magickMVm8lp created in the home directory? If you execute

# restorecon -R -v /home

does it help?

Comment 3 Yajo 2013-07-06 08:30:12 UTC
Description of problem:
Browsing /boot/grub2/themes

Additional info:
reporter:       libreport-2.1.5
hashmarkername: setroubleshoot
kernel:         3.9.8-300.fc19.x86_64
type:           libreport

Comment 4 Yajo 2013-07-06 08:38:51 UTC
(In reply to Miroslav Grepl from comment #2)
> Where is magickMVm8lp created in the home directory? If you execute

[yajo@localhost ~]$ find -name "*magickvMctbn*"
[yajo@localhost ~]$ find -name "*magickMVm8lp*"

No results.

> # restorecon -R -v /home
> 
> does it help?

My last comment was done with the automatic assistant.

I did not know what caused the error, so I executed that line and did what Garve said, and this happened again, but with the file "magickvMctbn.

Comment 5 Daniel Walsh 2013-07-09 21:28:30 UTC
Can imagemagick be changed to create this kind of cache data under ~/.cache/ImageMagick

Or something like that rather then scribbling all over the homedir.

Comment 6 Pavel Alexeev 2013-07-14 19:16:24 UTC

*** This bug has been marked as a duplicate of bug 825874 ***


Note You need to log in before you can comment on or make changes to this bug.