Bug 980673 - IndexError: list index out of range
IndexError: list index out of range
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: mulhern
Fedora Extras Quality Assurance
abrt_hash:b7445a598ed3bfd6749150bf492...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-02 22:32 EDT by Wellington Uemura
Modified: 2017-01-30 07:32 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-18 07:41:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (516.56 KB, text/plain)
2013-07-02 22:32 EDT, Wellington Uemura
no flags Details
File: anaconda.log (12.04 KB, text/plain)
2013-07-02 22:32 EDT, Wellington Uemura
no flags Details
File: environ (440 bytes, text/plain)
2013-07-02 22:32 EDT, Wellington Uemura
no flags Details
File: lsblk_output (3.12 KB, text/plain)
2013-07-02 22:33 EDT, Wellington Uemura
no flags Details
File: messages (197.02 KB, text/plain)
2013-07-02 22:33 EDT, Wellington Uemura
no flags Details
File: nmcli_dev_list (3.55 KB, text/plain)
2013-07-02 22:33 EDT, Wellington Uemura
no flags Details
File: os_info (179 bytes, text/plain)
2013-07-02 22:33 EDT, Wellington Uemura
no flags Details
File: program.log (50.41 KB, text/plain)
2013-07-02 22:33 EDT, Wellington Uemura
no flags Details
File: storage.log (168.82 KB, text/plain)
2013-07-02 22:33 EDT, Wellington Uemura
no flags Details
File: ifcfg.log (573 bytes, text/plain)
2013-07-02 22:33 EDT, Wellington Uemura
no flags Details

  None (edit)
Description Wellington Uemura 2013-07-02 22:32:41 EDT
Version-Release number of selected component:
anaconda-19.30.13-1.fc19.x86_64

The following was filed automatically by anaconda:
anaconda 19.30.13-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 791, in _updateSpaceDisplay
    summaryLabel = self._summaryButton.get_children()[0]
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 829, in refresh
    self._updateSpaceDisplay()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 109, in _runSpoke
    action.refresh()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 403, in _on_spoke_clicked
    self._runSpoke(spoke)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 419, in _on_spoke_clicked
    self._on_spoke_clicked(self._spokes[dest].selector, None, self._spokes[dest])
IndexError: list index out of range

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=LIVE rootfstype=vfat ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.5-301.fc19.x86_64
product:        Fedora
release:        Fedora release 19 (Schrödinger’s Cat)
type:           anaconda
version:        19

Potential duplicate: bug 880754
Comment 1 Wellington Uemura 2013-07-02 22:32:49 EDT
Created attachment 768014 [details]
File: anaconda-tb
Comment 2 Wellington Uemura 2013-07-02 22:32:53 EDT
Created attachment 768015 [details]
File: anaconda.log
Comment 3 Wellington Uemura 2013-07-02 22:32:58 EDT
Created attachment 768016 [details]
File: environ
Comment 4 Wellington Uemura 2013-07-02 22:33:03 EDT
Created attachment 768017 [details]
File: lsblk_output
Comment 5 Wellington Uemura 2013-07-02 22:33:08 EDT
Created attachment 768018 [details]
File: messages
Comment 6 Wellington Uemura 2013-07-02 22:33:13 EDT
Created attachment 768019 [details]
File: nmcli_dev_list
Comment 7 Wellington Uemura 2013-07-02 22:33:18 EDT
Created attachment 768020 [details]
File: os_info
Comment 8 Wellington Uemura 2013-07-02 22:33:22 EDT
Created attachment 768021 [details]
File: program.log
Comment 9 Wellington Uemura 2013-07-02 22:33:27 EDT
Created attachment 768022 [details]
File: storage.log
Comment 10 Wellington Uemura 2013-07-02 22:33:32 EDT
Created attachment 768023 [details]
File: ifcfg.log
Comment 11 Samantha N. Bueno 2013-07-02 23:27:20 EDT
Can you provide a set of steps taken to reproduce this?
Comment 12 Wellington Uemura 2013-07-03 11:59:53 EDT
It happens at the hdd selection, the installation proccess detect the HDD with 0 free space. When I try to customize it there are one partition with the size of the whole HDD named 'zfs_member', than this happened.

I can mount and unmount the partition outside the installation process, I can use also use gparted to access the HDD without any issue.
Comment 13 grupobetatesting 2013-09-13 15:55:24 EDT
Hello, we are a group of students of the National University of Comahue, from Neuquen Argentina. We were installing Fedora 19 for Desktop, when we selected the pendrive for install, then come back to main menu and it reported a bug. We hope you reply. Thanks!  

cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=Fedora-Live-XFCE-i686-19-1 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
hashmarkername: anaconda
kernel:         3.9.5-301.fc19.i686
package:        anaconda-19.30.13-1.fc19.i686
packaging.log:  
product:        Fedora
reason:         IndexError: list index out of range
release:        Fedora release 19 (Schrödinger’s Cat)
version:        19
Comment 14 mulhern 2013-10-07 12:27:31 EDT
Hi!

Could you be more specific about the sequence of steps that got you to this point? I can not reproduce partly because I can not get Fedora into a state where it allows an HDD with 0 free space.

Thanks!
Comment 15 mulhern 2013-10-07 14:00:32 EDT
This is probably a transitory and hard to reproduce error. The reason for this is that the summary button's children are set by the summary.glade file, i.e., statically. Therefore, it should _always_ have a label button, and so the index error should _never_ occur.

Obviously it has occurred, but I suspect a cause unrelated to the code that is actually failing.
Comment 16 grupobetatesting 2013-10-09 14:54:47 EDT
Basicaly the bug originates when we want  install the operating system in the usb flash drive. (the pendrive working properly and and it has enough free space 8GB) after creating the partition table , then come back to main menu and it reported a bug. 
After many attempts finally leave us install the operating system but the error is still.

We hope you reply. Thanks!
Comment 17 David Shea 2013-10-16 14:02:59 EDT
I may have inadvertently fixed whatever went wrong here (by removing the code).

https://lists.fedorahosted.org/pipermail/anaconda-patches/2013-October/006630.html
Comment 18 mulhern 2013-10-18 09:42:03 EDT
Likely your IndexError is caused by something other than the originally reported IndexError.

If you see it again, please upload a stack trace.

Thanks!
Comment 19 mulhern 2013-11-18 07:41:27 EST
The comments tell more, but it looks like the bug that was originally reported may have been removed by the time I got a chance to look at it.
Comment 20 Wellington Uemura 2017-01-30 07:32:15 EST
All requests fulfilled, please close this bug.

Note You need to log in before you can comment on or make changes to this bug.