Bug 980675 - When I run ls directories, symlinks, etc are colored but not bold also as they were before.
When I run ls directories, symlinks, etc are colored but not bold also as the...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: coreutils (Show other bugs)
19
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-02 22:37 EDT by Georgiy Treyvus
Modified: 2013-07-03 04:21 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-03 02:54:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Georgiy Treyvus 2013-07-02 22:37:57 EDT
This isn't a big deal and is a minor issue. Since directories, symlinks, etc are still colored it's still quite possible to easily distinguish between them visually. Still in most distributions not only are these things colored but they're also bold and when they're not it just feels awkward. It was even this way with Fedora 17 and earlier. In Fedora 18 this problem occured for root but not a normal user. In Fedora 19 this is the case for all users.

This is a minor problem. Furthermore this problem may even be a deliberate change. The /etc/DIR_COLORS* certainly didn't edit themselves. If this is deliberate can someone explain the reasoning behind the change.

This is a minor issue but is still annoying so please look into this.
Comment 1 Ondrej Vasik 2013-07-03 02:54:07 EDT
This bold/nonbold behaviour depends on the TERM environmental variable and terminal capabilities. If you have terminal with 256 color capabilities, it has different settings - 256 colors allows one set of colors for both lightbackground and darkbackground terminals. Most probably, 256 color support was enabled in your terminal.
Files in user homedir have even higher priority, so if you symlink /etc/DIR_COLORS to ~/.dir_colors , you'll get your old bold colorization - that one is still default for terminals without 256 color capabilities. As this change is based on terminal capabilities and is expected, closing that report NOTABUG.
Comment 2 Pádraig Brady 2013-07-03 04:21:13 EDT
It's amazing what one gets used too :)
What Ondřej says is correct.
I'll just add that, bold was only an artifact of selecting bright colors,
which 16 color terminals could not select independently of the bold attribute.
Details on the 256 color feature are at:
http://fedoraproject.org/wiki/Features/256_Color_Terminals

Note You need to log in before you can comment on or make changes to this bug.