Bug 980676 - Virt-manager will hang there while specify the disk during the rhel7 guest installation
Virt-manager will hang there while specify the disk during the rhel7 guest i...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libvirt (Show other bugs)
7.0
x86_64 Linux
high Severity high
: beta
: ---
Assigned To: Ján Tomko
Virtualization Bugs
: TestBlocker
: 985372 (view as bug list)
Depends On:
Blocks: RHEL7CCC
  Show dependency treegraph
 
Reported: 2013-07-02 22:41 EDT by zhenfeng wang
Modified: 2014-06-17 20:51 EDT (History)
17 users (show)

See Also:
Fixed In Version: libvirt-1.1.1-1.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 09:16:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description zhenfeng wang 2013-07-02 22:41:01 EDT
Description of problem:
Virt-manager will hang there while specify the disk type qcow2  or select an existing disk during the rhel7 guest installation

Version-Release number of selected component (if applicable):
virt-manager-0.10.0-1.el7.noarch
libvirt-1.1.0-1.el7.x86_64
qemu-kvm-1.5.1-1.el7.x86_64
kernel-3.10.0-0.rc7.64.el7.x86_64
How reproducible:
100%

Steps
1.#virt-manager

2.select Network install

3.Input the correct url
 http://download.englab.nay.redhat.com/pub/rhel/rel-eng/latest-RHEL-7/compose/Server/x86_64/os/

4.specify the guest's disk type qcow2 or select an existing disk, then the virt-manager will hang there after I type the forward button
select managed or other existing storage =>Browse=>New Volume=>specy the format qcow2=>finish=>choose the qcow2 disk=>forward


5.while the virt-manager hang there ,check the defalut vol-list ,this command will also hang there
# virsh vol-list defualt
^C
# virsh vol-dumpxml default guest.img
^C

6.The libvirtd service didn't hang there,other virsh command still works well

7.The guest can be installed successfully in libvirt-1.0.6-1.el7.x86_64

Actual results:
The guest can't be installed with the virt-manager in rhel7

Expected results:
The guest should be installed successfully with the virt-manager
Comment 2 tingting zheng 2013-07-02 23:13:48 EDT
If I have installed a guest,then try to add another disk to the guest,virt-manager will hang as described.

Also I tried to use virsh to create a volume in the pool,it can create successfully.
Comment 3 Luwen Su 2013-07-03 02:40:14 EDT
I reproduce it only with virsh command , so this is maybe a libvirt's bug.

Same packages with commend 0

1.create two img for testing
# qemu-img create -f raw /var/lib/libvirt/images/aaa.img 10M
Formatting '/var/lib/libvirt/images/aaa.img', fmt=raw size=10485760 
# qemu-img create -f raw /var/lib/libvirt/images/bbb.img 10M
Formatting '/var/lib/libvirt/images/bbb.img', fmt=raw size=10485760 

#virsh pool-refresh default
Pool default refreshed

2.to reproduce the issue
#virsh vol-key /var/lib/libvirt/images/aaa.img 
/var/lib/libvirt/images/aaa.img

#virsh vol-key /var/lib/libvirt/images/bbb.img 
//hang here

And all commands that related "vol" and "pool" will hang too.

# virsh hostname
localhost.localdomain

#virsh pool-list --all
//hang here
Comment 4 Shanzhi Yu 2013-07-03 05:00:23 EDT
I can reproduce it. Also, I met a similar problem "virsh vol-clone" will hang, after that, all commands related with "vol" and "pool" will hang too.

1.# virsh vol-list default 
Name                 Path                                    
-----------------------------------------
kvm-rhel6.3-x86_64-qcow2.img /var/lib/libvirt/images/kvm-rhel6.3-x86_64-qcow2.img

2. # virsh vol-clone /var/lib/libvirt/images/kvm-rhel6.3-x86_64-qcow2.img  test.img
// hang here
// CTRL+c to cancel

3. # virsh list 
 Id    Name                           State
----------------------------------------------------
 2     kvm-rhel6.3-x86_64-qcow2-virtio running

4. # systemctl restart libvirtd.service
//hang
 
Does this the same problem as comment 0 ?
Comment 5 Cui Lei 2013-07-03 05:28:52 EDT
As the bug block virt-manager installation testing, virsh command testing, set the TestBlocker on it
Comment 7 Martin Kletzander 2013-07-03 10:56:42 EDT
Looks like libvirt-1.1.0 has few locking problems.  However, this is not related to virt-manager, reassigning to libvirt.
Comment 8 Ján Tomko 2013-07-04 08:54:30 EDT
Upstream patch proposed:
https://www.redhat.com/archives/libvir-list/2013-July/msg00291.html
Comment 9 Ján Tomko 2013-07-04 09:47:24 EDT
Now fixed upstream:

commit fe89fd3b4071242ce9bbae6e1178fee30dc2f4f9
Author:     Ján Tomko <jtomko@redhat.com>
AuthorDate: 2013-07-04 14:41:46 +0200
Commit:     Ján Tomko <jtomko@redhat.com>
CommitDate: 2013-07-04 14:41:46 +0200

    Unlock the storage volume object after looking it up
    
    Introduced by c930410.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=980676

git describe: v1.1.0-50-gfe89fd3
Comment 10 Ján Tomko 2013-07-17 08:53:20 EDT
*** Bug 985372 has been marked as a duplicate of this bug. ***
Comment 14 zhe peng 2013-07-31 02:44:04 EDT
Can reproduce this with build:
libvirt-1.1.0-2.el7.x86_64

verify with libvirt-1.1.1-1.el7.x86_64

step:

1.create two img for testing
# qemu-img create -f raw /var/lib/libvirt/images/aaa.img 10M
Formatting '/var/lib/libvirt/images/aaa.img', fmt=raw size=10485760 
# qemu-img create -f raw /var/lib/libvirt/images/bbb.img 10M
Formatting '/var/lib/libvirt/images/bbb.img', fmt=raw size=10485760 

#virsh pool-refresh default
Pool default refreshed

#virsh vol-key /var/lib/libvirt/images/aaa.img 
/var/lib/libvirt/images/aaa.img

# virsh vol-key /var/lib/libvirt/images/bbb.img 
/var/lib/libvirt/images/bbb.img

no hang occured.

# virsh vol-clone /var/lib/libvirt/images/aaa.img test.img
Vol test.img cloned from aaa.img

# systemctl restart libvirtd.service
no hang occured. worked as expect. move to verified.
Comment 15 Ludek Smid 2014-06-13 09:16:22 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.