Bug 980691 - Upgrade to Hibernate 4.2.3.Final
Upgrade to Hibernate 4.2.3.Final
Status: CLOSED WONTFIX
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: JPA (Show other bugs)
6.1.0
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Scott Marlow
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-02 23:32 EDT by Brett Meyer
Modified: 2015-09-01 00:00 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-03 09:04:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brett Meyer 2013-07-02 23:32:48 EDT
If at all possible, we'd like to upgrade EAP 6.1.1 to Hibernate 4.2.3.Final (I'll be releasing it tomorrow morning).  Apologies for asking so close to the component freeze date, but we were waiting on feedback on a few tickets.
Comment 1 Brett Meyer 2013-07-02 23:46:45 EDT
Alternatively, since 4.2.3.Final would be brand new, could we consider 4.2.2.Final + a few cherry-picks?
Comment 2 Martin Simka 2013-07-03 05:06:02 EDT
As new features are not allowed in EAP 6.1.1 I'm unsure about few commits since Hibernate 4.2.0

HHH-7714 Add support for EntityMode.MAP to JPA Criteria API
and most of OSGI related commits e.g. HHH-7993 Support jar scanning in OSGi, HHH-7995 Auto-discovery of Hibernate extension points in OSGi (HHH-7944), ...

OSGI in EAP is only technical preview and is not supported
Comment 3 Brett Meyer 2013-07-03 08:49:44 EDT
Martin has a point about HHH-7714 and potentially a few other "new releases", although some of them are definitely a gray area.  However, I have no problem cherry-picking only the necessary commits for 6.1.1.
Comment 4 Brett Meyer 2013-07-03 09:04:45 EDT
I'm withdrawing this -- there's a few other concerns about compatability.  Thanks for the comment, Martin.

Note You need to log in before you can comment on or make changes to this bug.