Bug 980711 - [RFE]the priority box should be shown always
[RFE]the priority box should be shown always
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: web UI (Show other bugs)
0.13
Unspecified Unspecified
medium Severity high (vote)
: 24.0
: ---
Assigned To: Blake McIvor
tools-bugs
: EasyFix, FutureFeature, Patch, Reopened, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-03 01:48 EDT by wangjing
Modified: 2017-02-21 13:48 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-02-21 13:48:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot1 for comment0 (113.93 KB, image/png)
2013-07-03 01:48 EDT, wangjing
no flags Details
screenshot2 for comment0 (115.58 KB, image/png)
2013-07-03 01:48 EDT, wangjing
no flags Details

  None (edit)
Description wangjing 2013-07-03 01:48:06 EDT
Created attachment 768087 [details]
screenshot1 for comment0

Description of problem:
the priority box was not shown again.

Version-Release number of selected component (if applicable):
beaker-devel Version - 0.13.1

How reproducible:
always.

Steps to Reproduce:
1. submit a new job.
2. visit the job page at once.
3. refresh the page and check the priority box.

Actual results:
1. at beginning there is a priority box beside 'RecipeSet ID', see attachment1 [details].
2. several seconds later, the priority box was not shown again, see attachment2 [details].

Expected results:
hope to see the priority all the time.

Additional info:
Comment 1 wangjing 2013-07-03 01:48:47 EDT
Created attachment 768088 [details]
screenshot2 for comment0
Comment 3 Raymond Mancy 2013-07-03 02:48:42 EDT
This is a feature, not a Bug. Once the recipeset is running the priority is no longer relevant.
Comment 4 wangjing 2013-07-04 04:50:33 EDT
hi, I changed the summary to 'RFE', because:
1. the priority is an attribute, it could be set before running, and also could be seen when running.
2. now the priority could be changed by schedual automatically in some conditions, so the priority should be displayed so that user could see it easily, or else user only could see the priority on the cloning page(these days I checked the priority by cloning all the time, and not clear why it disappeared when running, it also could be displayed as long as it cannot be changed)

thanks.
Comment 7 Roman Joost 2016-05-27 17:41:32 EDT
The priority button disappears once the recipe moves on to Installing. Buttons should never disappear based on state.
Comment 8 sratnam 2016-05-30 02:27:12 EDT
(In reply to Roman Joost from comment #7)
> The priority button disappears once the recipe moves on to Installing.
> Buttons should never disappear based on state.

Should the priority of a recipeset be changeable during the installation state or any state for that matter?
Maybe that is the reason that it needs disappear during certain states?
Comment 9 Dan Callaghan 2016-06-15 23:17:45 EDT
(In reply to sratnam from comment #8)

Right. Once the recipe is Scheduled, it no longer makes sense to change the priority because it's not in the queue anymore, the priority has no effect.

So that's why currently the button just disappears. The problem here is there is no way to know what the priority *was* after the button has disappeared, because the priority is not shown anywhere else.

(Also the button disappearing based on state is violating our own UI guidelines which say not to do that, because it can cause confusion, just like this bug.)

However we *do* need to make sure the UI reflects the fact that the priority cannot be changed after the recipe set is Scheduled. At that point we should be showing the priority but not letting the user change it.

So I think we need to do two things:

* make the Priority button always present, regardless of the state

* once a recipe set is Scheduled the priority modal needs to change to a read-only view of some sort

One option for making the priority modal read-only would be to just keep the existing button group and set disabled="disabled" on the buttons. Maybe also on the "Save Changes" button. But I'm not sure how that will look -- it might be too difficult to see what the priority was set to in that case. So we might need to come up with something different.
Comment 11 Blake McIvor 2016-08-01 02:34:23 EDT
https://gerrit.beaker-project.org/#/c/5104/
Comment 14 Dan Callaghan 2017-02-21 13:48:15 EST
Beaker 24.0 has been released.

Note You need to log in before you can comment on or make changes to this bug.