Bug 980723 - Dist-geo-rep : If geo rep session is not started and user execute stop command, it gives error "Staging failed on ..Please check the log file for more details." instead of telling session is not started
Dist-geo-rep : If geo rep session is not started and user execute stop comman...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: geo-replication (Show other bugs)
2.1
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Avra Sengupta
amainkar
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-03 02:40 EDT by Rachana Patel
Modified: 2015-04-20 07:56 EDT (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0.12rhs.beta4_1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 18:38:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rachana Patel 2013-07-03 02:40:55 EDT
Description of problem:
Distributed-geo-rep : If geo rep session is not started and user execute stop command, it gives error "Staging failed on ..Please check the log file for more details." instead of telling session is not started


Version-Release number of selected component (if applicable):
3.4.0.12rhs.beta1-1.el6rhs.x86_64


How reproducible:
always

Steps to Reproduce:
1. do all necessary setp tp create georep session
2.create geo rep session
3.now stop it before starting

[root@hulk ~]# gluster volume geo master2 10.70.43.147::slave2 create force
Creating geo-replication session between master2 & 10.70.43.147::slave2 has been successful
[root@hulk ~]# gluster volume geo master2 10.70.43.147::slave2 status
NODE                        MASTER     SLAVE                   HEALTH         UPTIME       
-------------------------------------------------------------------------------------------
wall.blr.redhat.com         master2    10.70.43.147::slave2    Not Started    N/A          
lannister.blr.redhat.com    master2    10.70.43.147::slave2    Not Started    N/A          
ironman.blr.redhat.com      master2    10.70.43.147::slave2    Not Started    N/A          
[root@hulk ~]# gluster volume geo master2 10.70.43.147::slave2 stop
Staging failed on 10.70.42.246. Please check the log file for more details.
Staging failed on 10.70.42.191. Please check the log file for more details.
Staging failed on 10.70.42.158. Please check the log file for more details.
geo-replication command failed

Actual results:
Staging failed on 10.70.42.246. Please check the log file for more details.
Staging failed on 10.70.42.191. Please check the log file for more details.
Staging failed on 10.70.42.158. Please check the log file for more details.
geo-replication command failed

from log file we can see that session is not started

Expected results:
It's better to inform User that session is not started.


Additional info:
Comment 2 Vijaykumar Koppad 2013-07-31 05:42:59 EDT
verified on 3.4.0.14rhs-1.el6rhs.x86_64
Comment 3 Scott Haines 2013-09-23 18:38:42 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html
Comment 4 Scott Haines 2013-09-23 18:41:28 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.