Bug 980750 - [RHSC] When a host is moved to Maintenance after being Non-operational, it is removed from the cluster, if another host in the cluster is UP.
[RHSC] When a host is moved to Maintenance after being Non-operational, it is...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.1
Unspecified Unspecified
medium Severity medium
: ---
: RHGS 2.1.2
Assigned To: Darshan
Shruti Sampat
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-03 03:39 EDT by Shruti Sampat
Modified: 2015-05-13 12:34 EDT (History)
10 users (show)

See Also:
Fixed In Version: CB6
Doc Type: Bug Fix
Doc Text:
Previously, when a non-operational host was moved to Maintenance mode, it was removed from the cluster. Now, with this update, the removal of host in Maintenance mode is disabled.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-25 02:32:33 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 19327 None None None Never

  None (edit)
Description Shruti Sampat 2013-07-03 03:39:02 EDT
Description of problem:
---------------------------------------
When a host in a cluster is UP, and another is added, if it ends up in Non-Operational state, the only way to reinstall that node is to move it to Maintenance and then reinstall. But after it is moved to Maintenance, the host is removed from the cluster.

Version-Release number of selected component (if applicable):
Red Hat Storage Console Version: 2.1.0-0.bb4.el6rhs 

How reproducible:
Always

Steps to Reproduce:
1. Add a host to a cluster via the Console, let it come UP.
2. Add another host, such that it ends up in Non-operational state. (could be due to absence of glusterfs packages)
3. Move the Non-operational host to Maintenance, inorder to reinstall.

Actual results:
Host is removed from the cluster.

Expected results:
The engine should allow a reinstall of the host after being moved to Maintenance.

Additional info:
Comment 3 Matt Mahoney 2013-11-07 14:41:21 EST
Verified CB6. Have not encountered this issue. Setting as Validated, and will reopen if it is seen again.
Comment 4 Shalaka 2014-01-06 05:48:35 EST
Please review the edited DocText and confirm.
Comment 6 errata-xmlrpc 2014-02-25 02:32:33 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0208.html

Note You need to log in before you can comment on or make changes to this bug.