Bug 980763 - Not initialized ESD sound in SDL
Not initialized ESD sound in SDL
Status: CLOSED DUPLICATE of bug 851349
Product: Fedora
Classification: Fedora
Component: SDL (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jaromír Cápík
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-03 04:09 EDT by vassun
Modified: 2016-01-31 20:58 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-23 07:24:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description vassun 2013-07-03 04:09:44 EDT
Description of problem:

Not initialized ESD sound in SDL

Version-Release number of selected component (if applicable):

SDL-1.2.15-9.fc19.x86_64
esound-libs-0.2.41-8.fc19.x86_64


How reproducible:

putenv ((char *) "SDL_AUDIODRIVER=esd");
...
// Open the audio device, forcing the desired formats
  if ((SDL_OpenAudio (&wanted, NULL) < 0))
    {
      printf ("Couldnt open SDL Audio : %s\n", SDL_GetError ());
      return false;
    }


Steps to Reproduce:
1.
2.
3.

Actual results:

Couldnt open SDL Audio : No available audio device


Expected results:


Additional info:
Comment 1 Jaromír Cápík 2013-07-18 11:29:53 EDT
Hello.

I'm unable to reproduce the issue here when pulseaudio is running. I get that message only when I kill pulseaudio with 'pulseaudio -k'.

Please, check and let me know.

Thanks.

Regards,
Jaromir.
Comment 2 vassun 2013-07-22 09:15:32 EDT
Hello,

I have this occur in both cases, running and stopped pulseaudio


after 'pulseaudio -k', stops working alsa audio too...
Comment 3 vassun 2013-07-23 05:07:53 EDT
please tell me how should I start ESD sound driver? and check if it works?
Comment 4 vassun 2013-07-23 06:02:42 EDT
I tried to run the following command:

esdcat -b -m -r 11025 test.wav

sound plays ok!

SDL can be compiled without support ESD? how to check?
Comment 5 vassun 2013-07-23 06:42:37 EDT
I removed the SDL-1.2.15-9  'rpm -e --nodeps SDL'
and installed from site http://www.libsdl.org/release/SDL-1.2.15-1.x86_64.rpm 

now the ESD sound is initialized correctly, the problem is
SDL-1.2.15-9.fc19.x86_64!!!, please return the support ESD in SDL!
Comment 6 Petr Pisar 2013-07-23 07:24:54 EDT
Esound support has been removed from SDL because Esound had been removed from Fedora. See bug #851349 for the removal request.

If you want to have Esound support back in Fedora SDL, you have to get back esound package first.
Comment 7 Petr Pisar 2013-07-23 08:15:06 EDT
(In reply to Petr Pisar from comment #6)
> Esound support has been removed from SDL because Esound had been removed
> from Fedora. See bug #851349 for the removal request.
> 
> If you want to have Esound support back in Fedora SDL, you have to get back
> esound package first.

Seems the esound has never been expunged completely and some maintainers still takes care about it. I will readd the support for Esound into the SDL.

*** This bug has been marked as a duplicate of bug 851349 ***
Comment 8 vassun 2013-07-23 09:18:55 EDT
(In reply to Petr Pisar from comment #6)
> Esound support has been removed from SDL because Esound had been removed
> from Fedora. See bug #851349 for the removal request.
> 
> If you want to have Esound support back in Fedora SDL, you have to get back
> esound package first.


why Esound had been removed from Fedora ?

Esound present in Fedora ?!

esound-devel, esound-libs, esound-tools... 

they are available in the repositories ?!
Comment 9 Jaromír Cápík 2013-07-24 07:59:44 EDT
Hello.

I've discussed that with Petr and it looks more like a misinformation. He's gonna reintroduce the esound support in SDL.

Regards,
Jaromir.

Note You need to log in before you can comment on or make changes to this bug.