Bug 980775 - Queries using temporal operators do not return results
Queries using temporal operators do not return results
Status: CLOSED CURRENTRELEASE
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: BRE (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity high
: ER4
: 6.0.0
Assigned To: Edson Tirelli
Tomas David
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-03 04:26 EDT by Marek Winkler
Modified: 2014-08-06 16:16 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:16:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marek Winkler 2013-07-03 04:26:16 EDT
Description of problem:

Queries using temporal queries return empty QueryResults, despite adding KieSession.fireAllRules() as required by phreak.

Please see pull request with the reproducer (CepQueryTest) for more details.


Version-Release number of selected component (if applicable):

Drools 6.0.0-SNAPSHOT
Drools 6.0.0.Beta4

This worked in 6.0.0.Beta3, marking as regression.


How reproducible:

Run the CepQueryTest (currently @Ignored) in drools-compiler integration tests.


Actual results:

Empty QueryResults are returned.


Expected results:

One event is returned in the query result.


Additional info:

The test uses two entry points but the problem is not related to them.
Comment 1 Marek Winkler 2013-07-03 04:30:08 EDT
Pull request containing the reproducer: https://github.com/droolsjbpm/drools/pull/219
Comment 2 Marek Winkler 2013-09-06 14:31:31 EDT
I have found this problem persists with ER2. Strangely, the query returns results when EventProcessingMode is set to CLOUD.
Comment 7 Tomas David 2013-10-16 05:37:28 EDT
Verified on BRMS 6.0.0.ER4.

Queries using temporal operators now return results, but new problem has appeared (Bug 1019708).

Note You need to log in before you can comment on or make changes to this bug.