Bug 980797 - When mate panels are configured to be vertical (on left and right), space between labels disappears.
When mate panels are configured to be vertical (on left and right), space bet...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: mate-window-manager (Show other bugs)
19
athlon Linux
unspecified Severity medium
: ---
: ---
Assigned To: Dan Mashal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-03 05:09 EDT by jd1008
Modified: 2013-07-03 14:06 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-03 13:12:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jd1008 2013-07-03 05:09:15 EDT
Description of problem:
When the launch panel is moved to left side of screen, the space between
"Applications"
"Places"
"System"

disappears, and they looks like one long word.


Version-Release number of selected component (if applicable):
mate-window-manager-1.6.2-3.fc19.x86_64

How reproducible:
Move the launch panel to left side of screen

Steps to Reproduce:
1.
2.
3.

Actual results:
See Description of problem above.

Expected results:
Space between the three app launchers: Applications, Places, and System

Additional info:
Comment 1 Wolfgang Ulbrich 2013-07-03 10:31:11 EDT
Seems to be a theme issue. Which theme are you using?
Comment 2 jd1008 2013-07-03 10:59:43 EDT
(In reply to Wolfgang Ulbrich from comment #1)
> Seems to be a theme issue. Which theme are you using?

I did not choose any theme that I know of.
I juet chose the defaults.
I only changed the desktop background to Silk.

That's it!

So, if it is a a theme issue, which theme should I use, (choose?) and how do I do so?

Regards,

JD
Comment 3 jd1008 2013-07-03 11:31:22 EDT
On the Right Panel (which is not the LAUNCH panel,
the virtual workspaces are considerably narrower than the panel.
This leads to am unexpected effect:
The only way I can see the icon of the running application
in the virtual desktop displayed in the right panel, is to make the width
of the right panel 43 pixels.
When I was using gnome 2, I only had to set the width of the panel to 33 pixels.

Also, when I go the virtual desktop, it does n ot show the icons
of the apps running in that desktop on the right panel, so if I iconify
the app, it disappears for good, and I am unable to
un-iconify it.

If this behaviour is also caused by the theme, Please advise
how I can fix it.

Regards,

JD
Comment 4 Wolfgang Ulbrich 2013-07-03 11:42:51 EDT
(In reply to jd1008 from comment #2)
> (In reply to Wolfgang Ulbrich from comment #1)
> > Seems to be a theme issue. Which theme are you using?
> 
> I did not choose any theme that I know of.
> I juet chose the defaults.
> I only changed the desktop background to Silk.
> 
> That's it!
> 
> So, if it is a a theme issue, which theme should I use, (choose?) and how do
> I do so?
> 
> Regards,
> 
> JD
Ok, than you use the Menta theme, which is MATE's default.
I can confirm that it happens here too.
But with all other GTK2/3 MATE themes like TraditionalOK, TraditionalGreen, GreenLaguna, BlackMATE, TraditionalOkTest, this will never happens.

Sorry, I can't fix Menta for this 'very special case of using the menu amd panels', because this will change the general appearance of the panel.
Comment 5 Wolfgang Ulbrich 2013-07-03 11:44:37 EDT
(In reply to jd1008 from comment #3)
> On the Right Panel (which is not the LAUNCH panel,
> the virtual workspaces are considerably narrower than the panel.
> This leads to am unexpected effect:
> The only way I can see the icon of the running application
> in the virtual desktop displayed in the right panel, is to make the width
> of the right panel 43 pixels.
> When I was using gnome 2, I only had to set the width of the panel to 33
> pixels.
> 
> Also, when I go the virtual desktop, it does n ot show the icons
> of the apps running in that desktop on the right panel, so if I iconify
> the app, it disappears for good, and I am unable to
> un-iconify it.
> 
> If this behaviour is also caused by the theme, Please advise
> how I can fix it.
> 
> Regards,
> 
> JD

Same thing play with themes.
Comment 6 jd1008 2013-07-03 12:11:10 EDT
I am no expert with themes.
How do I "play" with themes?

Please elucidate.

Regards,

JD
Comment 7 Wolfgang Ulbrich 2013-07-03 12:22:52 EDT
Use 'mate-appearance-properties' in a terminal.
In the open window there is a theme tab.
Here you can change the theme.
Comment 8 jd1008 2013-07-03 13:01:02 EDT
(In reply to Wolfgang Ulbrich from comment #7)
> Use 'mate-appearance-properties' in a terminal.
> In the open window there is a theme tab.
> Here you can change the theme.

I selected Quid theme, and that fixed the spaces between
Applications
Places
System

However, I still do not see the large icon on the right panel for currently running aps in a workspace that is in focus and active.
Thus I still am unable to un-iconify an iconified app.
Comment 9 Wolfgang Ulbrich 2013-07-03 13:12:57 EDT
Fine that it works.
Comment 10 jd1008 2013-07-03 14:06:33 EDT
(In reply to Wolfgang Ulbrich from comment #9)
> Fine that it works.

Then I will have to open a new bug for the part:

"However, I still do not see the large icon on the right panel for currently running aps in a workspace that is in focus and active.
Thus I still am unable to un-iconify an iconified app."

Note You need to log in before you can comment on or make changes to this bug.