Bug 980806 - Wireless adapter obstructs wired connection
Wireless adapter obstructs wired connection
Status: CLOSED DUPLICATE of bug 928220
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: fedora-kernel-wireless-ath
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-03 05:38 EDT by Eugene Saenko
Modified: 2013-07-03 10:19 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-03 10:19:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 928220 None None None Never

  None (edit)
Description Eugene Saenko 2013-07-03 05:38:07 EDT
Description of problem:
If there are both:
wired network adapter (Atheros Communications Inc. AR8152 v2.0 Fast Ethernet (rev c1), driver atl1c)
and
wireless (Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01), driver ath9k)

and only wired connection is in use (wireless adapter isn't connected to AP but is enabled by hardware switch), wired connection is braked off after 2 to 3 minutes of normal work. 
Link can be rectored by unplug network cable and plug in again.

Version-Release number of selected component (if applicable):
# lspci | awk '/[nN]et/{print $1}' | xargs -i lspci -knns {}
01:00.0 Ethernet controller [0200]: Atheros Communications Inc. AR8152 v2.0 Fast Ethernet [1969:2062] (rev c1)
        Subsystem: Lenovo Device [17aa:3979]
        Kernel driver in use: atl1c
02:00.0 Network controller [0280]: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) [168c:002b] (rev 01)
        Subsystem: Lenovo Device [17aa:30a1]
        Kernel driver in use: ath9k
# uname -a
Linux ses-laptop.localnet 3.9.6-200.fc18.i686.PAE #1 SMP Thu Jun 13 19:19:30 UTC 2013 i686 i686 i386 GNU/Linux



How reproducible:


Steps to Reproduce:
1. Turn on computer and plug-in network cable
2. Ping remote host

  
Actual results:
$ ping utro.ru
..............
..............
64 bytes from www-martan.utro.ru (194.186.36.190): icmp_seq=168 ttl=248 time=41.5 ms
64 bytes from www-martan.utro.ru (194.186.36.190): icmp_seq=169 ttl=248 time=43.4 ms
64 bytes from www-martan.utro.ru (194.186.36.190): icmp_seq=170 ttl=248 time=44.7 ms
64 bytes from www-martan.utro.ru (194.186.36.190): icmp_seq=171 ttl=248 time=70.6 ms
64 bytes from www-martan.utro.ru (194.186.36.190): icmp_seq=172 ttl=248 time=45.7 ms
64 bytes from www-martan.utro.ru (194.186.36.190): icmp_seq=173 ttl=248 time=42.4 ms
64 bytes from www-martan.utro.ru (194.186.36.190): icmp_seq=174 ttl=248 time=44.4 ms
From ses-laptop.localnet (192.168.1.79) icmp_seq=200 Destination Host Unreachable
From ses-laptop.localnet (192.168.1.79) icmp_seq=201 Destination Host Unreachable
From ses-laptop.localnet (192.168.1.79) icmp_seq=202 Destination Host Unreachable

Expected results:
Continuous sequence of echo replies.


Additional info:
If wireless adapter is disabled by hardware switch, the wired network works OK.
Comment 1 Kasun Chathuranga 2013-07-03 09:36:58 EDT
I have same problem with these two.

02:00.0 Network controller: Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller (rev 01)
03:00.0 Ethernet controller: Atheros Communications Inc. AR8152 v1.1 Fast Ethernet (rev c1)

I revert back AR8152 driver to little old version and make it some how run.
Comment 2 Neil Horman 2013-07-03 10:19:37 EDT
I'm going to merge this with the other bz I'm working that involves these two components.  What atl1c driver version do you revert back to that makes this work?  I'm trying to find a good start point for a bisect.

*** This bug has been marked as a duplicate of bug 928220 ***

Note You need to log in before you can comment on or make changes to this bug.