Bug 980846 - Duplicate use of parameter -h in virt-viewer/remote-viewer manual
Summary: Duplicate use of parameter -h in virt-viewer/remote-viewer manual
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-viewer
Version: 6.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Daniel Berrangé
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks: 980848
TreeView+ depends on / blocked
 
Reported: 2013-07-03 10:51 UTC by tingting zheng
Modified: 2013-11-21 08:11 UTC (History)
8 users (show)

Fixed In Version: virt-viewer-0.5.6-2.el6
Doc Type: Bug Fix
Doc Text:
no doc required
Clone Of:
: 980848 (view as bug list)
Environment:
Last Closed: 2013-11-21 08:11:13 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1578 0 normal SHIPPED_LIVE virt-viewer bug fix and enhancement update 2013-11-20 21:39:50 UTC

Description tingting zheng 2013-07-03 10:51:12 UTC
Description
Duplicate use of parameter -h in virt-viewer/remote-viewer manual

Version:
virt-viewer-0.5.6-1.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
# man virt-viewer
OPTIONS
       The following options are accepted when running "virt-viewer":

       -h, --help
           Display command line help summary

       -h HOTKEYS, --hotkeys HOTKEYS
           Override the default hotkey bindings with HOTKEYS. Where HOTKEYS is
           <action1>=<key1>[+<key2>][,<action2>=<key3>[+<key4>]]. Key-names are case-insensitive,
           valid actions are: toggle-fullscreen, release-cursor, smartcard-insert and smartcard-
           remove. Examples:

             --hotkeys=toggle-fullscreen=shift+f11,release-cursor=shift+f12

             --hotkeys=release-cursor=ctrl+alt

           Note that hotkeys for which no binding is given are disabled, specifying an empty string
           disables all hotkeys.


# man remote-viewer
OPTIONS
       The following options are accepted when running "remote-viewer":

       -h, --help
           Display command line help summary

       -h HOTKEYS, --hotkeys HOTKEYS
           Override the default hotkey bindings with HOTKEYS. Where HOTKEYS is
           <action1>=<key1>[+<key2>][,<action2>=<key3>[+<key4>]]. Key-names are case-insensitive,
           valid actions are: toggle-fullscreen, release-cursor, smartcard-insert and smartcard-
           remove. Examples:

             --hotkeys=toggle-fullscreen=shift+f11,release-cursor=shift+f12

             --hotkeys=release-cursor=ctrl+alt

           Note that hotkeys for which no binding is given are disabled, specifying an empty string
           disables all hotkeys.

# virt-viewer -h
Missing argument for -h
Run 'virt-viewer --help' to see a full list of available command line options


# remote-viewer -h
Missing argument for -h
Run 'remote-viewer --help' to see a full list of available command line options



Actual results:
Duplicate parameter -h in virt-viewer/remote-viewer manual

Expected results:
Only one use for parameter -h in virt-viewer/remote-viewer manual

Additional info:

Comment 2 CongDong 2013-07-03 11:15:18 UTC
The content in man page and help message are different about the help option:
It's "-?" in "--help" message, but it's "-h" in man page

# virt-viewer --help
...
Help Options:
  -?, --help                                                        Show help options
...

# remote-viewer --help
...
Help Options:
  -?, --help                                                        Show help options
...

# man virt-viewer 
...
OPTIONS
       The following options are accepted when running "virt-viewer":

       -h, --help
           Display command line help summary
...

# man remote-viewer
...
OPTIONS
       The following options are accepted when running "remote-viewer":

       -h, --help
           Display command line help summary
...

Comment 3 Daniel Berrangé 2013-07-03 11:24:42 UTC
This is a regression caused by

  commit 008491a2d99b626877898a6782cf4c2010bbb7db
  Author: Hans de Goede <hdegoede@redhat.com>
  Date:   Wed Dec 19 15:56:43 2012 +0100

    Make hotkey configuration functionality available from the cmdline (v2)
    

which broke the existing usage of '-h' as an alias for --help. I'd suggest the hotkeys should be exposed using '-H'

Comment 5 tingting zheng 2013-07-09 12:11:19 UTC
Tested with:
virt-viewer-0.5.6-3.el6.x86_64

# man virt-viewer
       -H HOTKEYS, --hotkeys HOTKEYS
           Override the default hotkey bindings with HOTKEYS. Where HOTKEYS is
           <action1>=<key1>[+<key2>][,<action2>=<key3>[+<key4>]]. Key-names are case-insensitive,
           valid actions are: toggle-fullscreen, release-cursor, smartcard-insert and smartcard-
           remove. Examples:

             --hotkeys=toggle-fullscreen=shift+f11,release-cursor=shift+f12

             --hotkeys=release-cursor=ctrl+alt

           Note that hotkeys for which no binding is given are disabled, specifying an empty string
           disables all hotkeys.

# virt-viewer -h
  -H, --hotkeys                                       Customise hotkeys


# man remote-viewer
       -H HOTKEYS, --hotkeys HOTKEYS
           Override the default hotkey bindings with HOTKEYS. Where HOTKEYS is
           <action1>=<key1>[+<key2>][,<action2>=<key3>[+<key4>]]. Key-names are case-insensitive,
           valid actions are: toggle-fullscreen, release-cursor, smartcard-insert and smartcard-
           remove. Examples:

             --hotkeys=toggle-fullscreen=shift+f11,release-cursor=shift+f12

             --hotkeys=release-cursor=ctrl+alt

           Note that hotkeys for which no binding is given are disabled, specifying an empty string
           disables all hotkeys.

# remote-viewer -h

  -H, --hotkeys                                        Customise hotkeys


So refer to the above comments,move the bug to VERIFIED.

Comment 6 errata-xmlrpc 2013-11-21 08:11:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1578.html


Note You need to log in before you can comment on or make changes to this bug.