Bug 980852 - Can not save vnc and spice password when ssh to remote machine and launch virt-manager
Can not save vnc and spice password when ssh to remote machine and launch vir...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-manager (Show other bugs)
6.5
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: virt-mgr-maint
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-03 07:06 EDT by tingting zheng
Modified: 2014-01-20 05:29 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-20 05:29:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of saving password on rhel6 (81.57 KB, image/png)
2013-07-03 07:09 EDT, tingting zheng
no flags Details
screenshot of saving password on rhel7 (73.97 KB, image/png)
2013-07-03 07:09 EDT, tingting zheng
no flags Details

  None (edit)
Description tingting zheng 2013-07-03 07:06:49 EDT
Description
Can not save vnc and spice password when ssh to remote machine and launch virt-manager

Version:
virt-manager-0.9.0-18.el6.x86_64
libvirt-0.10.2-18.el6_4.9.x86_64

How reproducible:
100%

Steps to Reproduce:
1.On machine A,prepare a guest,set password for vnc or spice.
2.Boot the guest.
3.On machine B,ssh to machine A,launch virt-manager.
4.Open the guest which has been set vnc or spice password,the "Save this password in your keyring" is disabled.

Actual results:
On rhel6, the "Save this password in your keyring" is disabled.
On rhel7, the "Save this password in your keyring" is enabled.

Expected results:
Can save vnc and spice password when ssh to remote machine and launch virt-manager

Additional info:
Attched the screenshot for both rhel6 and rhel7
Comment 1 tingting zheng 2013-07-03 07:09:02 EDT
Created attachment 768196 [details]
screenshot of saving password on rhel6
Comment 2 tingting zheng 2013-07-03 07:09:36 EDT
Created attachment 768197 [details]
screenshot of saving password on rhel7
Comment 4 Martin Kletzander 2013-07-16 01:01:30 EDT
Do you have a keyring available?  Try explicitly running one and make sure dbus is running as well.  rhel6/7 is installed on the machine you are ssh'ing "to" or "from"?
Comment 5 tingting zheng 2013-07-16 02:13:25 EDT
(In reply to Martin Kletzander from comment #4)
> Do you have a keyring available?  Try explicitly running one and make sure
> dbus is running as well.  rhel6/7 is installed on the machine you are
> ssh'ing "to" or "from"?

Not sure whether I've understand your meaning.Checked these systems,dbus is running.I didn't find keyring showed as a process in command ps.

Totally 3 machines,A and B with rhel 6 system,C with rhel 7 system.

1.Prepare a guest,set password for vnc or spice.On machine A,B,C,after boot the guest,the passowrd can be inputed and "Save this password in your keyring" is enabled.

2.On machine A,ssh machine B,launch virt-manager,boot the guest,the passowrd can be inputed and "Save this password in your keyring" is disabled.

3.On machine A,ssh machine C,launch virt-manager,boot the guest,the passowrd can be inputed and "Save this password in your keyring" is enabled.
Comment 6 Martin Kletzander 2013-07-16 03:33:39 EDT
OK, I figured that out.  The difference is that with moving to Gtk3, we are using different backend for keyrings.  On rhel7 this works because we use dbus for saving/collecting secrets but on rhel6 we're stuck with local gnome-keyring.  That said, I must stress out that locally the saving should work on rhel6, this problem will be visible only while running virt-manager in ssh session.
Comment 7 luxin 2013-07-30 02:57:41 EDT
I can reproduce this bug

In rhel6:
   Version:
   virt-manager-0.9.0-18.el6.x86_64
   libvirt-0.10.2-18.el6_4.9.x86_64

   Steps to Reproduce:
   1.On machine A,prepare a guest,set password for vnc or spice.
   2.Boot the guest.
   3.On machine B,ssh to machine A,launch virt-manager.
   4.Open the guest which has been set vnc or spice password,the "Save this     password in your keyring" is disabled.

   Actual results:
   On rhel6, the "Save this password in your keyring" is disabled.

   Expected results:
   Can save vnc and spice password when ssh to remote machine and launch    virt-manager,and the "Save this password in your keyring" is enabled.

In rhel7:
   Version:
   virt-manager-0.10.0-1.el7.noarch
   libvirt-1.0.6-1.el7.x86_64

   Steps to Reproduce:
   1.On machine A,prepare a guest,set password for vnc or spice.
   2.Boot the guest.
   3.On machine B,ssh to machine A,launch virt-manager.
   4.Open the guest which has been set vnc or spice password,the "Save this password in your keyring" is disabled.

   Actual results:
   On rhel7, the "Save this password in your keyring" is enabled.

   Expected results:
   Can save vnc and spice password when ssh to remote machine and launch virt-manager,and the "Save this password in your keyring" is enabled.
Comment 8 Giuseppe Scrivano 2014-01-20 05:29:58 EST
since it looks like a RFE and it is not affecting any user, I am going to close it.  Please reopen if you disagree.

Note You need to log in before you can comment on or make changes to this bug.