Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 980868 - Cannot deploy distributable application when is defined jdbc-store for web session
Summary: Cannot deploy distributable application when is defined jdbc-store for web se...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Clustering
Version: 6.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ER4
: EAP 6.1.1
Assignee: Radoslav Husar
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 981260
TreeView+ depends on / blocked
 
Reported: 2013-07-03 12:00 UTC by Tomas Remes
Modified: 2013-09-16 20:22 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-09-16 20:22:24 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Issue Tracker WFLY-1632 0 None None None Never

Description Tomas Remes 2013-07-03 12:00:29 UTC
Using following infinispan subsystem configuration is causing CNF org.infinispan.loaders.jdbc.stringbased.JdbcStringBasedCacheStore

<cache-container name="web" aliases="standard-session-cache" default-cache="local-web" module="org.jboss.as.clustering.web.infinispan">
    <local-cache name="local-web" batching="true">
        <string-keyed-jdbc-store datasource="java:jboss/datasources/ExampleDS" passivation="false" preload="true" purge="false">
            <property name="databaseType">H2</property>
            <string-keyed-table prefix="stringbased">
                <id-column name="id" type="VARCHAR"/>
                <data-column name="datum" type="BINARY"/>
                <timestamp-column name="version" type="BIGINT"/>
            </string-keyed-table>
        </string-keyed-jdbc-store>
     </local-cache>
</cache-container>

Workaround is to add following to /org/infinispan/main/module.xml:

<module name="org.infinispan.cachestore.jdbc"/>

Full stack:

13:48:27,130 ERROR [org.jboss.msc.service.fail] (ServerService Thread Pool -- 6) MSC000001: Failed to start service jboss.infinispan.web.default-host/jdbcStore: org.jboss.msc.service.StartException in service jboss.infinispan.web.default-host/jdbcStore: org.infinispan.CacheException: Unable to invoke method public void org.infinispan.loaders.CacheLoaderManagerImpl.start() on object of type CacheLoaderManagerImpl
	at org.jboss.as.clustering.msc.AsynchronousService$1.run(AsynchronousService.java:87)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145) [rt.jar:1.7.0_21]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615) [rt.jar:1.7.0_21]
	at java.lang.Thread.run(Thread.java:722) [rt.jar:1.7.0_21]
	at org.jboss.threads.JBossThread.run(JBossThread.java:122) [jboss-threads-2.1.0.Final-redhat-1.jar:2.1.0.Final-redhat-1]
Caused by: org.infinispan.CacheException: Unable to invoke method public void org.infinispan.loaders.CacheLoaderManagerImpl.start() on object of type CacheLoaderManagerImpl
	at org.infinispan.util.ReflectionUtil.invokeAccessibly(ReflectionUtil.java:205)
	at org.infinispan.factories.AbstractComponentRegistry$PrioritizedMethod.invoke(AbstractComponentRegistry.java:886)
	at org.infinispan.factories.AbstractComponentRegistry.invokeStartMethods(AbstractComponentRegistry.java:657)
	at org.infinispan.factories.AbstractComponentRegistry.internalStart(AbstractComponentRegistry.java:646)
	at org.infinispan.factories.AbstractComponentRegistry.start(AbstractComponentRegistry.java:549)
	at org.infinispan.factories.ComponentRegistry.start(ComponentRegistry.java:217)
	at org.infinispan.CacheImpl.start(CacheImpl.java:582)
	at org.infinispan.manager.DefaultCacheManager.wireAndStartCache(DefaultCacheManager.java:686)
	at org.infinispan.manager.DefaultCacheManager.createCache(DefaultCacheManager.java:649)
	at org.infinispan.manager.DefaultCacheManager.getCache(DefaultCacheManager.java:545)
	at org.infinispan.manager.DefaultCacheManager.getCache(DefaultCacheManager.java:559)
	at org.jboss.as.clustering.infinispan.DefaultEmbeddedCacheManager.getCache(DefaultEmbeddedCacheManager.java:109)
	at org.jboss.as.clustering.infinispan.DefaultEmbeddedCacheManager.getCache(DefaultEmbeddedCacheManager.java:100)
	at org.jboss.as.clustering.infinispan.subsystem.CacheService.start(CacheService.java:78)
	at org.jboss.as.clustering.msc.AsynchronousService$1.run(AsynchronousService.java:82)
	... 4 more
Caused by: org.infinispan.CacheException: Unable to start cache loaders
	at org.infinispan.loaders.CacheLoaderManagerImpl.start(CacheLoaderManagerImpl.java:160)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) [rt.jar:1.7.0_21]
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57) [rt.jar:1.7.0_21]
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) [rt.jar:1.7.0_21]
	at java.lang.reflect.Method.invoke(Method.java:601) [rt.jar:1.7.0_21]
	at org.infinispan.util.ReflectionUtil.invokeAccessibly(ReflectionUtil.java:203)
	... 18 more
Caused by: org.infinispan.CacheConfigurationException: Unable to instantiate class org.infinispan.loaders.jdbc.stringbased.JdbcStringBasedCacheStore
	at org.infinispan.util.Util.loadClass(Util.java:101)
	at org.infinispan.util.Util.getInstance(Util.java:222)
	at org.infinispan.loaders.CacheLoaderManagerImpl.createCacheLoader(CacheLoaderManagerImpl.java:344)
	at org.infinispan.loaders.CacheLoaderManagerImpl.createCacheLoader(CacheLoaderManagerImpl.java:334)
	at org.infinispan.loaders.CacheLoaderManagerImpl.start(CacheLoaderManagerImpl.java:146)
	... 23 more
Caused by: java.lang.ClassNotFoundException: org.infinispan.loaders.jdbc.stringbased.JdbcStringBasedCacheStore
	at java.net.URLClassLoader$1.run(URLClassLoader.java:366) [rt.jar:1.7.0_21]
	at java.net.URLClassLoader$1.run(URLClassLoader.java:355) [rt.jar:1.7.0_21]
	at java.security.AccessController.doPrivileged(Native Method) [rt.jar:1.7.0_21]
	at java.net.URLClassLoader.findClass(URLClassLoader.java:354) [rt.jar:1.7.0_21]
	at java.lang.ClassLoader.loadClass(ClassLoader.java:423) [rt.jar:1.7.0_21]
	at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:308) [rt.jar:1.7.0_21]
	at java.lang.ClassLoader.loadClass(ClassLoader.java:356) [rt.jar:1.7.0_21]
	at java.lang.Class.forName0(Native Method) [rt.jar:1.7.0_21]
	at java.lang.Class.forName(Class.java:266) [rt.jar:1.7.0_21]
	at org.infinispan.util.Util.loadClassStrict(Util.java:138)
	at org.infinispan.util.Util.loadClass(Util.java:99)
	... 27 more

13:48:27,130 ERROR [org.jboss.msc.service.fail] (ServerService Thread Pool -- 23) MSC000001: Failed to start service jboss.infinispan.web.local-web: org.jboss.msc.service.StartException in service jboss.infinispan.web.local-web: org.infinispan.CacheException: Unable to invoke method public void org.infinispan.loaders.CacheLoaderManagerImpl.start() on object of type CacheLoaderManagerImpl
	at org.jboss.as.clustering.msc.AsynchronousService$1.run(AsynchronousService.java:87)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145) [rt.jar:1.7.0_21]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615) [rt.jar:1.7.0_21]
	at java.lang.Thread.run(Thread.java:722) [rt.jar:1.7.0_21]
	at org.jboss.threads.JBossThread.run(JBossThread.java:122) [jboss-threads-2.1.0.Final-redhat-1.jar:2.1.0.Final-redhat-1]
Caused by: org.infinispan.CacheException: Unable to invoke method public void org.infinispan.loaders.CacheLoaderManagerImpl.start() on object of type CacheLoaderManagerImpl
	at org.infinispan.util.ReflectionUtil.invokeAccessibly(ReflectionUtil.java:205)
	at org.infinispan.factories.AbstractComponentRegistry$PrioritizedMethod.invoke(AbstractComponentRegistry.java:886)
	at org.infinispan.factories.AbstractComponentRegistry.invokeStartMethods(AbstractComponentRegistry.java:657)
	at org.infinispan.factories.AbstractComponentRegistry.internalStart(AbstractComponentRegistry.java:646)
	at org.infinispan.factories.AbstractComponentRegistry.start(AbstractComponentRegistry.java:549)
	at org.infinispan.factories.ComponentRegistry.start(ComponentRegistry.java:217)
	at org.infinispan.CacheImpl.start(CacheImpl.java:582)
	at org.infinispan.manager.DefaultCacheManager.wireAndStartCache(DefaultCacheManager.java:686)
	at org.infinispan.manager.DefaultCacheManager.createCache(DefaultCacheManager.java:649)
	at org.infinispan.manager.DefaultCacheManager.getCache(DefaultCacheManager.java:545)
	at org.infinispan.manager.DefaultCacheManager.getCache(DefaultCacheManager.java:559)
	at org.jboss.as.clustering.infinispan.DefaultEmbeddedCacheManager.getCache(DefaultEmbeddedCacheManager.java:109)
	at org.jboss.as.clustering.infinispan.DefaultEmbeddedCacheManager.getCache(DefaultEmbeddedCacheManager.java:100)
	at org.jboss.as.clustering.infinispan.subsystem.CacheService.start(CacheService.java:78)
	at org.jboss.as.clustering.msc.AsynchronousService$1.run(AsynchronousService.java:82)
	... 4 more
Caused by: org.infinispan.CacheException: Unable to start cache loaders
	at org.infinispan.loaders.CacheLoaderManagerImpl.start(CacheLoaderManagerImpl.java:160)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) [rt.jar:1.7.0_21]
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57) [rt.jar:1.7.0_21]
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) [rt.jar:1.7.0_21]
	at java.lang.reflect.Method.invoke(Method.java:601) [rt.jar:1.7.0_21]
	at org.infinispan.util.ReflectionUtil.invokeAccessibly(ReflectionUtil.java:203)
	... 18 more
Caused by: org.infinispan.CacheConfigurationException: Unable to instantiate class org.infinispan.loaders.jdbc.stringbased.JdbcStringBasedCacheStore
	at org.infinispan.util.Util.loadClass(Util.java:101)
	at org.infinispan.util.Util.getInstance(Util.java:222)
	at org.infinispan.loaders.CacheLoaderManagerImpl.createCacheLoader(CacheLoaderManagerImpl.java:344)
	at org.infinispan.loaders.CacheLoaderManagerImpl.createCacheLoader(CacheLoaderManagerImpl.java:334)
	at org.infinispan.loaders.CacheLoaderManagerImpl.start(CacheLoaderManagerImpl.java:146)
	... 23 more
Caused by: java.lang.ClassNotFoundException: org.infinispan.loaders.jdbc.stringbased.JdbcStringBasedCacheStore
	at java.net.URLClassLoader$1.run(URLClassLoader.java:366) [rt.jar:1.7.0_21]
	at java.net.URLClassLoader$1.run(URLClassLoader.java:355) [rt.jar:1.7.0_21]
	at java.security.AccessController.doPrivileged(Native Method) [rt.jar:1.7.0_21]
	at java.net.URLClassLoader.findClass(URLClassLoader.java:354) [rt.jar:1.7.0_21]
	at java.lang.ClassLoader.loadClass(ClassLoader.java:423) [rt.jar:1.7.0_21]
	at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:308) [rt.jar:1.7.0_21]
	at java.lang.ClassLoader.loadClass(ClassLoader.java:356) [rt.jar:1.7.0_21]
	at java.lang.Class.forName0(Native Method) [rt.jar:1.7.0_21]
	at java.lang.Class.forName(Class.java:266) [rt.jar:1.7.0_21]
	at org.infinispan.util.Util.loadClassStrict(Util.java:138)
	at org.infinispan.util.Util.loadClass(Util.java:99)
	... 27 more

Comment 1 Radoslav Husar 2013-07-08 16:08:20 UTC
The issue affects using Hot Rod remote cache store as well, not only JDBC store.

Comment 2 Radoslav Husar 2013-07-09 09:02:48 UTC
PR https://github.com/jbossas/jboss-eap/pull/227

Comment 3 Tomas Remes 2013-07-31 07:45:39 UTC
Verified in 6.1.1.ER4 release.

Comment 4 Scott Mumford 2013-08-06 03:35:42 UTC
Since this issue seems to go from broken to verified in only a few comments (and the github link 404s); more information is required about what was causing the problem, how it manifested, how it was fixed and the current behavior of the product (CCFR: in the Doc Text field above).

Comment 5 Scott Mumford 2013-08-29 01:04:14 UTC
Marking for exclusion from the 6.1.1 Release Notes document as an entry for this bug could not be completed or verified in time.


Note You need to log in before you can comment on or make changes to this bug.