Bug 98089 - cdrecord permissions problem for users other than root
cdrecord permissions problem for users other than root
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: cdrecord (Show other bugs)
9
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-26 10:08 EDT by Leonard Evens
Modified: 2007-04-18 12:55 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-24 08:43:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Leonard Evens 2003-06-26 10:08:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
Normally one should be able to burn a CD by dragging and dropping in the
///:burn folder and then clicking on the create CD button.  This works as root,
but it doesn't work as another user on my machine.  I also can't burn a CD as
another user using cdrecord directly, and that may be where the problem lies.  I
get the following messages when I try.

Cdrecord 2.0 (i686-pc-linux-gnu) Copyright (C) 1995-2002 J?rg Schilling
TOC Type: 1 = CD-ROM
cdrecord: Operation not permitted. WARNING: Cannot do mlockall(2).
cdrecord: WARNING: This causes a high risk for buffer underruns.
cdrecord: Operation not permitted. WARNING: Cannot set RR-scheduler
cdrecord: Permission denied. WARNING: Cannot set priority using setpriority().
cdrecord: WARNING: This causes a high risk for buffer underruns.
scsidev: '1,4,0'
scsibus: 1 target: 4 lun: 0
cdrecord: Permission denied. Cannot open '/dev/sg0'. Cannot open SCSI driver.
cdrecord: For possible targets try 'cdrecord -scanbus'. Make sure you are root.
cdrecord: For possible transport specifiers try 'cdrecord dev=help'.

My system has a Tekram Dc-390U SCSI controller which has two SCSI buses.  My CD
is a Plextor PX-W1210TS SCSI drive.  (I also have a separate non writing IDE CD
drive.)  I have two SCSI hard drives which appear as devices sg0 (sda) and sg1
(sdb) which are on the first SCSI bus.  The CD writer is on the second SCSI bus
at 1,4,0 and appears as sg2.

With the current entries in /etc/security/console.perms, when I login I find
that I own /dev/sg2 as expected.   But the above error messages suggest that for
some reason cdrecord is looking at sg0, and that may be where the permissions
problem arises.

crw-------    1 len      disk      21,   2 Jan 30 04:24 /dev/sg

The only fix I've found is that if I put myself in the disk group, then
everything works.


Version-Release number of selected component (if applicable):
cdrecord-2.0-6

How reproducible:
Always
Comment 1 Harald Hoyer 2003-06-26 10:14:27 EDT
'/dev/sg0' is made writeable to the console user... so you have to login
directly on the machine. If this solves your problem, I would say "NOTABUG"
Comment 2 John Franks 2003-06-27 13:55:07 EDT
I think this is a duplicate of 90565.  On this machine sg0 is a SCSI hard drive
and is not made writable to the console user.  Installation of the current
rawhide version of cdrecord should fix the problem, as it does for 90565.
Comment 3 Leonard Evens 2003-06-27 14:10:55 EDT
As John suggested, it appears that this was fixed by the new cdrecord.

Note You need to log in before you can comment on or make changes to this bug.