Bug 980899 - kde-settings-kdm %preun scriptlet fails, cannot be uninstalled
kde-settings-kdm %preun scriptlet fails, cannot be uninstalled
Status: CLOSED DUPLICATE of bug 989145
Product: Fedora
Classification: Fedora
Component: kde-settings (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-03 09:22 EDT by Michel Alexandre Salim
Modified: 2013-08-14 04:17 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-01 04:05:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michel Alexandre Salim 2013-07-03 09:22:05 EDT
Description of problem:
kde-settings-kdm has the following %preun scriptlet:

%{?systemd_preun:%system_preun kdm.service}

This fails when I attempted to remove kde from my computer, using

    yum remove kde\*



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. yum groupinstall "KDE Plasma Workspaces"
2. yum remove kde\*  # yum groupremove "KDE Plasma Workspaces" does not work
                     # somehow yum thinks the group is still not installed
3. yum remove kde-settings-kdm
4. rpm -e kde-settings-kdm

Actual results:
with yum:
/var/tmp/rpm-tmp.i61Oku: line 1: fg: no job control
error: %preun(kde-settings-kdm-19-23.fc19.noarch) scriptlet failed, exit status 1
Error in PREUN scriptlet in rpm package kde-settings-kdm-19-23.fc19.noarch

with rpm:
/var/tmp/rpm-tmp.Z8qeVJ: line 1: fg: no job control
error: %preun(kde-settings-kdm-19-23.fc19.noarch) scriptlet failed, exit status 1
error: kde-settings-kdm-19-23.fc19.noarch: erase failed


Expected results:
Should uninstall cleanly


Additional info:
Comment 1 Michel Alexandre Salim 2013-07-03 09:25:21 EDT
This is likely due to a typo: %system_preun should be %systemd_preun

$ rpm -E %system_preun
%system_preun

$ rpm -E %systemd_preun
if [ $1 -eq 0 ] ; then 
        # Package removal, not upgrade 
        /usr/bin/systemctl --no-reload disable  > /dev/null 2>&1 || : 
        /usr/bin/systemctl stop  > /dev/null 2>&1 || : 
fi
Comment 2 Rex Dieter 2013-07-03 09:29:13 EDT
indeed, icky typo, i'll fix it this week.
Comment 3 Martin Bříza 2013-08-01 04:05:56 EDT
I fixed this in the kde-settings-19-23.1 but according to fedora-kde list it doesn't fix the problem for those who already installed the package...
Closing this as a duplicate of the newer bug because that's the one that will be closed by bodhi.

*** This bug has been marked as a duplicate of bug 989145 ***
Comment 4 Marek Zdunek 2013-08-12 11:41:59 EDT
well after system update i have duplicate package error

"yum check" gives message

kde-settings-kdm-19-23.1.fc19.noarch jest duplikatem kde-settings-kdm-19-23.fc19.noarch

where "yum list kde-settings-kdm* output is
Zainstalowane pakiety
kde-settings-kdm.noarch 19-23.fc19      installed
kde-settings-kdm.noarch 19-23.1.fc19    @updates 

su -c "yum remove kde-settings-kdm-19-23.fc19.noarch" doesn't work
Comment 5 Rex Dieter 2013-08-12 11:45:50 EDT
doesn't work... how?  Can you post any output/error?
Comment 6 Lars Gullik Bjønnes 2013-08-12 15:35:58 EDT
(In reply to Rex Dieter from comment #5)
> doesn't work... how?  Can you post any output/error?

Running transaction
/var/tmp/rpm-tmp.qFaQ4E: line 1: fg: no job control
error: %preun(kde-settings-kdm-19-23.fc19.noarch) scriptlet failed, exit status 1
Error in PREUN scriptlet in rpm package kde-settings-kdm-19-23.fc19.noarch
  Verifying  : kde-settings-kdm-19-23.fc19.noarch                                     1/1 

Failed:
  kde-settings-kdm.noarch 0:19-23.fc19                                                    

Complete!


And the package is not removed.
Comment 7 Rex Dieter 2013-08-12 15:42:31 EDT
Ah, the dup'd bug has the workaround, which is:

rpm -e --noscripts kde-settings-kdm-19-23.fc19
Comment 8 Fisherman 2013-08-13 13:14:59 EDT
works like a charm, thanks

Note You need to log in before you can comment on or make changes to this bug.