Bug 980910 - Dist-geo-rep : Change in meta data of the files on master doesn't get propagated to slave.
Dist-geo-rep : Change in meta data of the files on master doesn't get propag...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: geo-replication (Show other bugs)
2.1
x86_64 Linux
high Severity medium
: ---
: ---
Assigned To: Ajeet Jha
Vijaykumar Koppad
: ZStream
Depends On:
Blocks: 1024467
  Show dependency treegraph
 
Reported: 2013-07-03 09:37 EDT by Vijaykumar Koppad
Modified: 2015-02-22 18:01 EST (History)
13 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0.36rhs-1
Doc Type: Bug Fix
Doc Text:
Previously, the geo-replication daemon never synced metadata changes to the file to the slave side, if metadata changes are done after files are created. With this update, geo-replication module syncs all the metadata changes to the file properly to slave.
Story Points: ---
Clone Of:
: 1024467 (view as bug list)
Environment:
Last Closed: 2013-11-27 10:26:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vijaykumar Koppad 2013-07-03 09:37:50 EDT
Description of problem: If you change a meta data of the file like chmod, chown, chgrp, touch, these won't get propagated to slave.


Version-Release number of selected component (if applicable):glusterfs-3.4.0.12rhs.beta1-1.el6rhs.x86_64 


How reproducible: Always


Steps to Reproduce:
1.Create and start a geo-rep session between master and slave.
2.Create some file and let it sync to slaves. 
3.Change meta data of the files, eg: do chmod 777 * on the mount point
4.Check meta data has been changed or not on the slave

Actual results: Meta data of the files won't get propagated.


Expected results: Meta data should be propagated to slaves.


Additional info:
Comment 2 Venky Shankar 2013-08-12 01:01:09 EDT
*** Bug 990458 has been marked as a duplicate of this bug. ***
Comment 4 Vijaykumar Koppad 2013-11-03 05:59:19 EST
verified on glusterfs-3.4.0.38rhs-1
Comment 6 errata-xmlrpc 2013-11-27 10:26:46 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1769.html

Note You need to log in before you can comment on or make changes to this bug.