Bug 980918 - fedup ISO F18->F19 fails with Exception in pipelogger
fedup ISO F18->F19 fails with Exception in pipelogger
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: fedup (Show other bugs)
18
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Will Woods
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-03 09:56 EDT by Jeremy Beker
Modified: 2013-12-22 00:34 EST (History)
3 users (show)

See Also:
Fixed In Version: fedup-0.8.0-3.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 02:22:08 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremy Beker 2013-07-03 09:56:20 EDT
Description of problem:

fedup performed with a local ISO ('fedup --iso /tmp/Fedora-19-x86_64-DVD.iso --debuglog=fedupdebug.log') exits with a python Exception:

setting up system for upgrade
Exception in thread pipelogger:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/threading.py", line 551, in __bootstrap_inner
    self.run()
  File "/usr/lib64/python2.7/threading.py", line 504, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib/python2.7/site-packages/fedup/upgrade.py", line 135, in pipelogger
    logger.log(thislevel, line.rstrip())
NameError: global name 'thislevel' is not defined


Version-Release number of selected component (if applicable):

fedup-0.7.3-4.fc18.noarch

How reproducible:

Always

Steps to Reproduce:
1. fedup --iso /tmp/Fedora-19-x86_64-DVD.iso --debuglog=fedupdebug.log

Actual results:

Command runs and gets to the step of "setting up system for upgrade" and then it dies with a Traceback:

Exception in thread pipelogger:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/threading.py", line 551, in __bootstrap_inner
    self.run()
  File "/usr/lib64/python2.7/threading.py", line 504, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib/python2.7/site-packages/fedup/upgrade.py", line 135, in pipelogger
    logger.log(thislevel, line.rstrip())
NameError: global name 'thislevel' is not defined

Expected results:

Upgrade to F19

Additional info:
Comment 1 Jeremy Beker 2013-07-03 11:23:26 EDT
This patch to /usr/lib/python2.7/site-packages/fedup/upgrade.py seems to fix it.  Looks like just a typo.


--- upgrade.py.orig	2013-07-03 11:21:40.832999959 -0400
+++ upgrade.py	2013-07-03 11:21:51.375128243 -0400
@@ -132,7 +132,7 @@
             if line.startswith('D: '):
                 logger.debug(line[3:].rstrip())
             else:
-                logger.log(thislevel, line.rstrip())
+                logger.log(level, line.rstrip())
         logger.info("got EOF")
     logger.info("exiting")
Comment 2 Will Woods 2013-07-24 16:00:58 EDT
Ayup, good catch. Fixed in commit b8ab72e:

 https://github.com/wgwoods/fedup/commit/b8ab72e

That'll be in the next fedup release. Thanks!
Comment 3 Fedora Update System 2013-12-11 17:12:12 EST
fedup-0.8.0-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/fedup-0.8.0-3.fc19
Comment 4 Fedora Update System 2013-12-11 17:20:27 EST
fedup-0.8.0-3.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/fedup-0.8.0-3.fc20
Comment 5 Fedora Update System 2013-12-11 17:22:16 EST
fedup-0.8.0-3.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/fedup-0.8.0-3.fc18
Comment 6 Fedora Update System 2013-12-13 00:09:39 EST
Package fedup-0.8.0-3.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing fedup-0.8.0-3.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-23316/fedup-0.8.0-3.fc19
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2013-12-19 02:22:08 EST
fedup-0.8.0-3.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2013-12-19 20:44:30 EST
fedup-0.8.0-3.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2013-12-22 00:34:39 EST
fedup-0.8.0-3.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.