Bug 98095 - postfix uses rmail.postfix and causes mails via UUCP to fail
postfix uses rmail.postfix and causes mails via UUCP to fail
Status: CLOSED RAWHIDE
Product: Red Hat Linux Beta
Classification: Retired
Component: postfix (Show other bugs)
beta4
All Linux
medium Severity medium
: ---
: ---
Assigned To: John Dennis
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-26 11:15 EDT by Nils Philippsen
Modified: 2007-04-18 12:55 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-26 16:19:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nils Philippsen 2003-06-26 11:15:51 EDT
Description of problem:

Postfix uses "rmail.postfix" instead of "rmail" as the command to execute when
sending mails over UUCP transports. Remote system gets confused, causes message
to fail. This is especially nasty since only the admin of the remote system gets
error messages.

Version-Release number of selected component (if applicable):

postfix-2.0.11-3

How reproducible:

Fairly easy.

Steps to reproduce:

1. Configure UUCP transport, try sending a message over the UUCP link.
2. See message fail on remote system

Additional info:

The error is in /etc/postfix/master.cf. These lines:

---- 8< ----
uucp      unix  -       n       n       -       -       pipe
  flags=Fqhu user=uucp argv=uux -r -n -z -a$sender - $nexthop!rmail.postfix
($recipient)
---- >8 ----

should read:

---- 8< ----
uucp      unix  -       n       n       -       -       pipe
  flags=Fqhu user=uucp argv=uux -r -n -z -a$sender - $nexthop!rmail ($recipient)
---- >8 ----
Comment 1 John Dennis 2003-06-26 13:45:07 EDT
2 Questions:

1) Did you use alternatives --config mta to select postfix as your mta?

2) Does editing the master.cf file to use just "rmail" work?

After selecting postfix as your mta rmail should be a link to rmail.postfix.
Comment 2 Nils Philippsen 2003-06-26 15:13:02 EDT
I can answer both questions with yes.

The point is that without the change I described postfix will put
"rmail.postfix" as the command to execute on the remote machine. Even if the
remote machine would have rmail.postfix, it doesn't work because "rmail.postfix"
most likely isn't in the list of commands that the UUCP system _may_ execute.
Comment 3 John Dennis 2003-06-26 16:19:31 EDT
fixed in postfix-2.0.11-4, removed patch to master.cf that set rmail to
rmail.postfix

Note You need to log in before you can comment on or make changes to this bug.