Bug 980966 - Installer and Live fail to start graphically with UEFI boot on Dell XPS 12 [NEEDINFO]
Installer and Live fail to start graphically with UEFI boot on Dell XPS 12
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
19
i686 Linux
unspecified Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-03 12:57 EDT by Dan Taylor
Modified: 2014-03-10 10:46 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-10 10:46:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
jforbes: needinfo?


Attachments (Terms of Use)

  None (edit)
Description Dan Taylor 2013-07-03 12:57:02 EDT
Description of problem:

Dell XPS 12 hardware

lspci shows 
host bridge: Intel Corp 3rd Gen Core processor DRAM Controller rev 09
VGA compatible controller: Intel Corp 3rgd gen core processor graphics controller (rev 09)
signal processing controller: Intel corp 3rd gen...
usb controller: intel corp 7 series/c210...
Communications controler: Intel Corp 7 series...
USB Controller: Intel Corp 7 series...
Audio device: Intel Corp 7 Series...
PCI bridge: Intel corp 7 series...
PCI bridge: Intel corp 7 series...
USB controller: Intel Corp 7 series...
ISA bridge: Intel corp qs77 express...
SATA colntroller: Intel corp 7 series...
SMBus: Intel corp 7 series...
Signal processing controller: Intel corp 7 series...
Network controller: Intel corp centrino advanced-N...

goal/desired behavior is dual UEFI boot win 8 / F19 with graphical desktop on F19

observed behavior: From F19 x86_64 install media, either USB stick or USB DVD; or from F19 Live USB stick, fails with black screen in default boot (no kernel options). Able to boot and get text install on install media, or text console on ctl-alt-f2 with Live by using xdriver=vesa or xdriver=intel (might require nomodeset). Unable to boot graphically with any of these media. If bios switched to Legacy/BIOS boot, graphical UI starts up as expected, but only if xdriver kernel parameters are supplied.

Version-Release number of selected component (if applicable):

Fedora 19 install dvd and Live Desktop iso as downloaded 2013.07.02

How reproducible:

100%

Steps to Reproduce:
1. set computer to use (U)EFI / secure boot
2. attempt to boot from USB Live Desktop, USB install media, or USB DVD drive with install media
3. supply kernel parameter for xdriver or start in basic graphics mode (starting with default kernel parameters produces black screen)

Actual results:
no graphical installation environment or Live Desktop environment with EFI boot

Expected results:
presence of graphical environment

Additional info:

After installing from USB stick F19 full install media, starting in EFI mode, booting F19 with default kernel parameters, startup hangs after reporting 'starting WPA Supplicant daemon'. text console is available on ctl-alt-f2. unable to start win8 from grub (presumably this is a separate issue).
Comment 1 ronin 2013-10-11 06:37:02 EDT
Still having these problems? Or did you get working?
I'm asking because i'm having exactly the same difficulties.
I also tried to use F17, with that one i was able to get a graphical environment.
But it wasn't that stable and not all hardware worked correctly.
Comment 2 Justin M. Forbes 2014-01-03 17:12:45 EST
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 19 kernel bugs.

Fedora 19 has now been rebased to 3.12.6-200.fc19.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you have moved on to Fedora 20, and are still experiencing this issue, please change the version to Fedora 20.

If you experience different issues, please open a new bug report for those.
Comment 3 Justin M. Forbes 2014-03-10 10:46:31 EDT
*********** MASS BUG UPDATE **************

This bug has been in a needinfo state for more than 1 month and is being closed with insufficient data due to inactivity. If this is still an issue with Fedora 19, please feel free to reopen the bug and provide the additional information requested.

Note You need to log in before you can comment on or make changes to this bug.