Bug 980970 - FUD lead engineering creates package incompatibilities
FUD lead engineering creates package incompatibilities
Status: CLOSED DUPLICATE of bug 981116
Product: Fedora
Classification: Fedora
Component: openstack-packstack (Show other bugs)
All All
unspecified Severity urgent
: ---
: ---
Assigned To: Honza Horak
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2013-07-03 13:19 EDT by Brian Aker
Modified: 2013-07-04 12:28 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2013-07-04 08:54:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Screenshot of your open stack installer blowing chunks. (26.55 KB, image/png)
2013-07-03 13:19 EDT, Brian Aker
no flags Details

  None (edit)
Description Brian Aker 2013-07-03 13:19:04 EDT
Description of problem:

By making decisions based on FUD, you have introduced a severe regression in Fedora 19 that influences all packages that require MySQL compatibility. As an example look at your own Open Stack installer. It appears that the open stack installer no longer works because of the alias introduced for the package named "mysql-installer".

Since the database you have attempted to replace mysql-server with has diverged, I can only imagine how annoying it is going to be to debug this longterm. I.E. This is just the icing on the cake.

How reproducible:

Start with your own open stack installer.

Steps to Reproduce:
1. Download Fedora 19.
2. Use http://openstack.redhat.com/Quickstart
3. (repeat)

Additional info:

How about restoring the packaging to what users expect and request? If end users want to react on FUD, let them make that decision. If Redhat wants to play the FUD game, then don't screw the end user. Do it by introducing a QA/CI process where you relink and test everything.

This slight of hand, "prey and hope it works", method of engineering doesn't make for a happy end user experience. Each database is its own special little thing,... you can't just slap a different one in and expect it to work.
Comment 1 Brian Aker 2013-07-03 13:19:55 EDT
Created attachment 768351 [details]
Screenshot of your open stack installer blowing chunks.
Comment 2 Fernando Cassia 2013-07-04 06:38:20 EDT
I also see this bug...
Comment 3 Honza Horak 2013-07-04 08:45:16 EDT
Thank you for reporting. As for the problem in OpenStack, reading discussion on [1], it is caused by the fact that puppet can't handle situation where two packages provide the same symbol. In this particular situation puppet see mariadb-server and community-mysql-server, both providing mysql-server symbol.

AFAICT, a quick fix should be (as proposed in [1]) to replace mysql-server by mariadb-server and mysql by mariadb for keys $client_package_name and $server_package_name in /usr/lib/python2.7/site-packages/packstack/puppet/modules/mysql/manifests/params.pp:

-$client_package_name = 'mysql'
-$server_package_name = 'mysql-server'
+$client_package_name = 'mariadb'
+$server_package_name = 'mariadb-server'

So I believe this should actually be fixed in openstack-packstack package, thus re-assigning.

However, this can happen any time in future again, since having the same symbol provided by more packages in one repository is not forbidden in Fedora. So IMHO puppet shouldn't panic in such situation, but should rather have some correctly defined algorithm to pick one.

[1] http://openstack.redhat.com/forum/discussion/124/fedora-19-issues#Comment_783

As for decisions made by FUD -- there are different requirements that sound like a must for someone and like a madness for someone else. We often need to find a compromise. Brian, if you want to talk about decisions about including packages in Fedora, let's move that discussion to fedora devel-list, so other users/maintainers can be involved.
Comment 4 Sandro Mathys 2013-07-04 08:54:17 EDT

*** This bug has been marked as a duplicate of bug 981116 ***

Note You need to log in before you can comment on or make changes to this bug.