Bug 980994 - Intel nuc does not boot fedora19
Intel nuc does not boot fedora19
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: efibootmgr (Show other bugs)
19
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-03 14:54 EDT by Ohad Basan
Modified: 2015-02-17 10:49 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-17 10:49:24 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sosreport (75.25 KB, text/plain)
2014-02-04 10:32 EST, hermelijn
no flags Details

  None (edit)
Description Ohad Basan 2013-07-03 14:54:09 EDT
Description of problem:

After finishing successfully installation of fedora 19
on an intel NUC (next unit of computing)
nuc's bios doesn't recognize a bootable device
Trying to boot the system throws a message

"A bootable device has not been detected"
Comment 1 hermelijn 2013-07-05 10:14:04 EDT
I ran into the same problem using fedora 19 on a intel NUC.
I managed to get it working by disabeling UEFI BIOS and use legacy bios only.
Comment 2 hermelijn 2013-07-08 07:40:32 EDT
To bad, the above workaround only works for the Live version of Fedora19.
I can't get the DVD version to boot in anyway. After selecting the "Install Fedora..." in the bootmenu it drops to a rescue prompt. journalctl will show that the /dev/root device doesn't exist.
Comment 3 Glen Z. 2013-07-16 10:52:15 EDT
I made a Live USB of Fedora 19 in Windows, installed,  and I have the same issue. I tried legacy bios but it still doesn't doesn't boot.
Comment 4 scott r 2013-08-25 17:47:16 EDT
Successfully installed full F19 from DVD:

NUC DC53427HYE  bios version:  RK0023.BIO Version:0023 Date:05/29/2013 Size:11.03 MB

Disabled the UEFI boot in bios 

editing the linux boot options on the main Installation page to: root=/dev/sr0 ( I am using an external USB DVD)

did NOT have the installer create a local user (the nuc seems to go through some failed reboots once you click the "reboot" button)

All seems to now work to include acpi

Ran geparted any blew away the first install and re-installed to make sure.
Comment 5 Hector Davie 2013-09-09 10:14:39 EDT
F19 claims to install on a NUC DC3217IYE, but after installation, BIOS claims it cannot find a boot device. Tried installing Ubuntu 12.0.4, which works straight out of the box (well, off the USB stick). Plextor mSATA SSD.
Comment 6 Fedora Admin XMLRPC Client 2013-10-09 16:37:48 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 7 Adam Williamson 2014-02-03 14:32:23 EST
We could do with the logs from /var/log/anaconda after an installation to debug what happened here: the bug is assigned to efibootmgr, but without any clear indication that's actually where the bug is, or any useful information to be able to figure out what the problem is even if the bug *is* in efibootmgr.
Comment 8 hermelijn 2014-02-04 10:31:50 EST
Seeing the above list I'm getting the feeling it's several different problems.
I can only speek for my own finding, so I reproduced my situation:
NUC D34010WYK, msata kingston SMS200S360G, booting from USB stick
Fedora LIVE 19 and 20 works fine (also centos and ubuntu)
Fedora 19 and 20 FULL DVD will not boot into installer, after a while the rescue prompt will appear. I'll upload the rdsosreport.txt, it's all I can provide.
Comment 9 hermelijn 2014-02-04 10:32:46 EST
Created attachment 859216 [details]
sosreport
Comment 10 Adam Williamson 2014-02-04 11:33:54 EST
I'm gonna guess you didn't write that USB stick with a Fedora utility, did you?

https://fedoraproject.org/wiki/How_to_create_and_use_Live_USB
Comment 11 Adam Williamson 2014-02-04 11:42:09 EST
Ah. I bet you used this, didn't you:

http://www.pendrivelinux.com/universal-usb-installer-easy-as-1-2-3/

Don't do that. 'Universal' USB writers rarely are.

Fedora's install images rely on a filesystem label to locate the partition with the installer itself on them. Note that cmdline has this:

Kernel command line: initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2020\x20x86_64 rd.live.check quiet BOOT_IMAGE=vmlinuz

'Universal' USB writers often don't write the correct label, as indeed it looks like UUI didn't. Your USB stick just has one big vfat partition on it, with the label "UUI":

/dev/sdb1: LABEL="UUI" UUID="1419-0665" TYPE="vfat" PARTUUID="fe3aea68-01" 

for a start the stick won't be UEFI bootable (a common problem with 'universal' stick writers), and for a second the lack of a label means the installer can't be located. You could probably boot with something like inst.stage2=hd:/dev/sdb1 (that's from memory, but the syntax is something like that), but I'd highly recommend just re-writing the stick using a recommended method, as there's no telling what else it got wrong.
Comment 12 hermelijn 2014-02-04 17:59:37 EST
That's correct Adam ;-), due to lack of time and resources I cut to many corners in my test today. The first cut was indeed using UUI instead of taking some time properly, the second was taking a NUC out of stock and not cheking the BIOS for UEFI. My original test was in legacy, but the helpdesk set all settings to UEFI including USB devices. Thanks for the heads up, I'll have another shot at it! (with a little more care :-)).
Comment 13 David Strauss 2014-02-06 16:18:10 EST
Has anyone tried Fedora 20?
Comment 15 Fedora End Of Life 2015-01-09 13:38:41 EST
This message is a notice that Fedora 19 is now at end of life. Fedora 
has stopped maintaining and issuing updates for Fedora 19. It is 
Fedora's policy to close all bug reports from releases that are no 
longer maintained. Approximately 4 (four) weeks from now this bug will
be closed as EOL if it remains open with a Fedora 'version' of '19'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 19 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 16 Fedora End Of Life 2015-02-17 10:49:24 EST
Fedora 19 changed to end-of-life (EOL) status on 2015-01-06. Fedora 19 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.