Bug 981010 - error while loading shared libraries: libHSleksah-0.12.1.3-ghc7.4.2.so: cannot open shared object file: No such file or directory
error while loading shared libraries: libHSleksah-0.12.1.3-ghc7.4.2.so: canno...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: leksah (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jens Petersen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-03 15:12 EDT by W. Andrew Denton
Modified: 2013-08-29 18:20 EDT (History)
2 users (show)

See Also:
Fixed In Version: leksah-0.12.1.3-12.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-29 18:20:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description W. Andrew Denton 2013-07-03 15:12:13 EDT
Description of problem:
In F19, leksah fails to run with this error:
leksah: error while loading shared libraries: libHSleksah-0.12.1.3-ghc7.4.2.so: cannot open shared object file: No such file or directory

This looks to be the same problem as bug #863499

The rpath of /bin/leksah contains 
/builddir/build/BUILD/leksah-0.12.1.3/dist/build
instead of
/usr/lib64/ghc-7.4.2/leksah-0.12.1.3/

As mentioned in #863499, I can work around the issue by setting LD_LIBRARY_PATH:
LD_LIBRARY_PATH=/usr/lib64/ghc-7.4.2/leksah-0.12.1.3/ leksah


Version-Release number of selected component (if applicable):
ghc-leksah-0.12.1.3-10.fc19.x86_64
leksah-server-0.12.1.2-10.fc19.x86_64
ghc-leksah-server-0.12.1.2-10.fc19.x86_64
leksah-0.12.1.3-10.fc19.x86_64

How reproducible:
Every time
Comment 1 Jens Petersen 2013-07-04 02:55:14 EDT
Thanks for reporting it, sorry about that...

This can be fixed by rebuilding leksah (without ghc-leksah-devel installed)
with latest ghc-rpm-macros-0.98.2-1.fc19 at least.

I may do some backporting from Rawhide soon to F19
which  should fix this at the same time.
Comment 2 Jens Petersen 2013-07-04 03:12:07 EDT
(yeah unfortunately it seems to be a re-occurrence of bug 863499)

I just checked the later rawhide build and it also has this problem
so seems the rpath munging is not working correctly in koji/mock perhaps.

Reassigning to ghc-rpm-macros.
Comment 3 Jens Petersen 2013-07-04 03:19:40 EDT
agda and pandoc seem okay.
Comment 4 Jens Petersen 2013-07-04 03:59:22 EDT
Actually this is just due to missing chrpath buildrequires in leksah.spec.
Comment 5 Jens Petersen 2013-07-04 04:04:08 EDT
This should be fixed initially in leksah-0.12.1.3-12.fc20.
Comment 6 Jens Petersen 2013-07-05 06:11:22 EDT
The next release of cabal-rpm should also generate the chrpath stuff automatically.
Comment 7 Fedora Update System 2013-08-20 08:59:09 EDT
leksah-0.12.1.3-12.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/leksah-0.12.1.3-12.fc19
Comment 8 Fedora Update System 2013-08-20 20:10:56 EDT
Package leksah-0.12.1.3-12.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing leksah-0.12.1.3-12.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-15069/leksah-0.12.1.3-12.fc19
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2013-08-29 18:20:47 EDT
leksah-0.12.1.3-12.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.