Bug 981017 - unable to print because of dbus error
unable to print because of dbus error
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
19
x86_64 Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-03 15:26 EDT by John Poelstra
Modified: 2013-08-08 09:49 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-08 09:49:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
error log (270.10 KB, text/plain)
2013-07-09 19:17 EDT, John Poelstra
no flags Details
ppd file (146.32 KB, application/vnd.cups-ppd)
2013-07-10 18:48 EDT, John Poelstra
no flags Details
print file (33.89 KB, application/pdf)
2013-07-10 18:49 EDT, John Poelstra
no flags Details

  None (edit)
Description John Poelstra 2013-07-03 15:26:12 EDT
Description of problem:

Unable to print from evince.  A few minutes before successfully printed from a different application.

Here's whats in /var/log/messages

Jul  3 11:58:39 xps dbus-daemon: dbus[693]: [system] Rejected send message, 2 matched rules; type="method_return", sender=":1.7" (uid=70 pid=689 comm="avahi-daemon: starting up ") interface="(unset)" member="(unset)" error name="(unset)" requested_reply="0" destination=":1.103" (uid=1000 pid=4643 comm="evince /tmp/detailedfunnel.pdf ")
Jul  3 11:58:39 xps dbus-daemon: dbus[693]: [system] Rejected send message, 2 matched rules; type="method_return", sender=":1.7" (uid=70 pid=689 comm="avahi-daemon: starting up ") interface="(unset)" member="(unset)" error name="(unset)" requested_reply="0" destination=":1.103" (uid=1000 pid=4643 comm="evince /tmp/detailedfunnel.pdf ")
Jul  3 11:58:39 xps dbus[693]: [system] Rejected send message, 2 matched rules; type="method_return", sender=":1.7" (uid=70 pid=689 comm="avahi-daemon: starting up ") interface="(unset)" member="(unset)" error name="(unset)" requested_reply="0" destination=":1.103" (uid=1000 pid=4643 comm="evince /tmp/detailedfunnel.pdf ")
Jul  3 11:58:39 xps dbus[693]: [system] Rejected send message, 2 matched rules; type="method_return", sender=":1.7" (uid=70 pid=689 comm="avahi-daemon: starting up ") interface="(unset)" member="(unset)" error name="(unset)" requested_reply="0" destination=":1.103" (uid=1000 pid=4643 comm="evince /tmp/detailedfunnel.pdf ")
Jul  3 11:58:40 xps systemd: Started CUPS Printing Service.
Jul  3 11:58:40 xps systemd: Started CUPS Printing Service.
Jul  3 11:59:12 xps systemd: Started CUPS Printing Service.
Jul  3 12:00:17 xps dbus-daemon: dbus[693]: [system] Rejected send message, 2 matched rules; type="method_return", sender=":1.7" (uid=70 pid=689 comm="avahi-daemon: starting up ") interface="(unset)" member="(unset)" error name="(unset)" requested_reply="0" destination=":1.103" (uid=1000 pid=4643 comm="evince /tmp/detailedfunnel.pdf ")
Jul  3 12:00:17 xps dbus[693]: [system] Rejected send message, 2 matched rules; type="method_return", sender=":1.7" (uid=70 pid=689 comm="avahi-daemon: starting up ") interface="(unset)" member="(unset)" error name="(unset)" requested_reply="0" destination=":1.103" (uid=1000 pid=4643 comm="evince /tmp/detailedfunnel.pdf ")
Jul  3 12:00:17 xps dbus-daemon: dbus[693]: [system] Rejected send message, 2 matched rules; type="method_return", sender=":1.7" (uid=70 pid=689 comm="avahi-daemon: starting up ") interface="(unset)" member="(unset)" error name="(unset)" requested_reply="0" destination=":1.103" (uid=1000 pid=4643 comm="evince /tmp/detailedfunnel.pdf ")
Jul  3 12:00:17 xps dbus[693]: [system] Rejected send message, 2 matched rules; type="method_return", sender=":1.7" (uid=70 pid=689 comm="avahi-daemon: starting up ") interface="(unset)" member="(unset)" error name="(unset)" requested_reply="0" destination=":1.103" (uid=1000 pid=4643 comm="evince /tmp/detailedfunnel.pdf ")
Jul  3 12:00:18 xps systemd: Started CUPS Printing Service.
Jul  3 12:00:49 xps systemd: Started CUPS Printing Service.
Jul  3 12:02:01 xps dbus[1354]: avc:  received setenforce notice (enforcing=0)
Jul  3 12:02:01 xps dbus[1186]: avc:  received setenforce notice (enforcing=0)
Jul  3 12:02:01 xps dbus[693]: avc:  received setenforce notice (enforcing=0)
Jul  3 12:02:01 xps dbus-daemon: dbus[693]: avc:  received setenforce notice (enforcing=0)
Jul  3 12:02:11 xps dbus-daemon: dbus[693]: [system] Rejected send message, 2 matched rules; type="method_return", sender=":1.7" (uid=70 pid=689 comm="avahi-daemon: starting up ") interface="(unset)" member="(unset)" error name="(unset)" requested_reply="0" destination=":1.103" (uid=1000 pid=4643 comm="evince /tmp/detailedfunnel.pdf ")
Jul  3 12:02:12 xps dbus[693]: [system] Rejected send message, 2 matched rules; type="method_return", sender=":1.7" (uid=70 pid=689 comm="avahi-daemon: starting up ") interface="(unset)" member="(unset)" error name="(unset)" requested_reply="0" destination=":1.103" (uid=1000 pid=4643 comm="evince /tmp/detailedfunnel.pdf ")
Jul  3 12:02:12 xps dbus[693]: [system] Rejected send message, 2 matched rules; type="method_return", sender=":1.7" (uid=70 pid=689 comm="avahi-daemon: starting up ") interface="(unset)" member="(unset)" error name="(unset)" requested_reply="0" destination=":1.103" (uid=1000 pid=4643 comm="evince /tmp/detailedfunnel.pdf ")
Jul  3 12:02:12 xps dbus-daemon: dbus[693]: [system] Rejected send message, 2 matched rules; type="method_return", sender=":1.7" (uid=70 pid=689 comm="avahi-daemon: starting up ") interface="(unset)" member="(unset)" error name="(unset)" requested_reply="0" destination=":1.103" (uid=1000 pid=4643 comm="evince /tmp/detailedfunnel.pdf ")
Jul  3 12:02:12 xps systemd: Started CUPS Printing Service.
Jul  3 12:02:12 xps systemd: Started CUPS Printing Service.
Jul  3 12:02:43 xps systemd: Started CUPS Printing Service.
Comment 1 Tim Waugh 2013-07-04 07:00:00 EDT
In what way were you unable to print? (Did you get an error?  Was the 'Print' button not sensitive?  Did the print come out wrong? ...)

Is there anything in /var/log/cups/error_log from this print attempt?
Comment 2 John Poelstra 2013-07-05 00:45:56 EDT
(In reply to Tim Waugh from comment #1)
> In what way were you unable to print? (Did you get an error?  Was the
> 'Print' button not sensitive?  Did the print come out wrong? ...)
> 
> Is there anything in /var/log/cups/error_log from this print attempt?

Great questions.  Sorry my bug report wasn't more detailed. 

No, there are no errors in /var/log/cups/error_log related to these print attempts.  

I just successfully:

1) completely removed
2) successfully added the printer
3) successfully printed test page


Then I open evince and go through print dialog to print last page of pdf and nothing happens--sometimes printer comes on (it's a laser printer) like it is going to start printing and then nothing happens.  Other times send multiple prints to it from evince and nothing happens at all.

I do see more error messages about avahi-daemon in /var/log/messages related to the document I was trying to print.

I just tried printing from LibreOffice and it prints fine.  

This appears to be a bug with Evince.  Feel free to re-assign to correct component.
Comment 3 Tim Waugh 2013-07-08 07:42:27 EDT
Please run these commands as root:

systemctl stop cups.service

>/var/log/cups/error_log

systemctl start cups.service

cupsctl --debug-logging

They will start again with an empty error_log file, and enable verbose logging.

Now try printing from Evince again. Finally, run this command as root:

cupsctl --no-debug-logging

to turn off verbose logging, and attach the /var/log/cups/error_log file here. Thanks.
Comment 4 John Poelstra 2013-07-09 19:17:26 EDT
Created attachment 771288 [details]
error log

here is the requested error_log.

Printer had not been in use all day.  Sent first print job to it and laser printer came on and sounded like it was going to print and then did nothing.  Sent the same print job again (reflected in the attached log) and this nothing happened, I'm assuming, because the laser printer was already on and in the ready position.
Comment 5 Tim Waugh 2013-07-10 04:34:32 EDT
There are some 'expected endobj' warnings from pdftopdf that I'd like to take a closer look at, and for that I'll need the job that CUPS received. Is it OK to make this public by attaching it here? Otherwise, please print from any file you don't mind getting attached here.

What I'd actually like to see is the document that CUPS received, not the document that evince reads. To get that, we'll need to tell CUPS to keep hold of it, like this:

cupsctl PreserveJobFiles=Yes

After doing this, please try printing from evince as before, and this time you should end up with a file in /var/spool/cups whose name begins with 'd'. Please attach that file here.

Please also attach /etc/cups/ppd/BINARY_P1.ppd. Thanks.
Comment 6 John Poelstra 2013-07-10 18:48:48 EDT
Created attachment 771889 [details]
ppd file
Comment 7 John Poelstra 2013-07-10 18:49:18 EDT
Created attachment 771890 [details]
print file
Comment 8 Tim Waugh 2013-07-11 11:38:11 EDT
Running pdftopdf against that PPD file and print file, I don't get any 'expected endobj' warnings.  Given that this file also failed to print for you, I don't think the 'expected endobj' warnings can be anything to do with the problem.

The next thing to try is changing the driver.  I'm not sure why you are using the gutenprint driver: system-config-printer-libs has the preferred driver as the one from foomatic-db-ppds ("Brother HL-5070N BR-Script3").  I guess you don't have foomatic-db-ppds installed, and there was no way to fetch the printer's Device ID through the print server it's attached to so there was no way to know to install foomatic-db-ppds automatically.

Could you please install foomatic-db-ppds, and system-config-printer if you don't already have that, and using system-config-printer to change the printer driver to "Brother HL-5070N BR-Script3", and try printing again?
Comment 9 John Poelstra 2013-08-01 11:17:54 EDT
(In reply to Tim Waugh from comment #8)
> Running pdftopdf against that PPD file and print file, I don't get any
> 'expected endobj' warnings.  Given that this file also failed to print for
> you, I don't think the 'expected endobj' warnings can be anything to do with
> the problem.
> 
> The next thing to try is changing the driver.  I'm not sure why you are
> using the gutenprint driver: system-config-printer-libs has the preferred
> driver as the one from foomatic-db-ppds ("Brother HL-5070N BR-Script3").  I
> guess you don't have foomatic-db-ppds installed, and there was no way to
> fetch the printer's Device ID through the print server it's attached to so
> there was no way to know to install foomatic-db-ppds automatically.
> 
> Could you please install foomatic-db-ppds, and system-config-printer if you
> don't already have that, and using system-config-printer to change the
> printer driver to "Brother HL-5070N BR-Script3", and try printing again?

Yes, this fixes the problem.  What's puzzling is that I configured the printer using the default tools in Fedora 19 (I don't believe system-config-printer is installed by default or the default tool).  Granted I started with the Fedora 19 alpha and 'yum updated' from there to where I am today--always using the official repos and not doing anything crazy.
Comment 10 Tim Waugh 2013-08-08 09:49:31 EDT
I think the issue is that, because it's connected to a print server and not directly connected, there is no way I know of to get at the printer's actual IEEE1284 Device ID, which is what the automatic printer driver installation mechanism keys off.

Note You need to log in before you can comment on or make changes to this bug.