Bug 981026 - evolution copies calendar synchronously (UI is blocked till the calendar copying is over)
evolution copies calendar synchronously (UI is blocked till the calendar copy...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: evolution (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity low
: beta
: ---
Assigned To: Matthew Barnes
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-03 15:55 EDT by David Jaša
Modified: 2013-07-08 11:30 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-08 11:30:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
evo bt (37.50 KB, text/plain)
2013-07-03 15:55 EDT, David Jaša
no flags Details
e-c-f bt (8.63 KB, text/plain)
2013-07-03 15:56 EDT, David Jaša
no flags Details
e-a-f bt (9.40 KB, text/plain)
2013-07-03 15:57 EDT, David Jaša
no flags Details

  None (edit)
Description David Jaša 2013-07-03 15:55:04 EDT
Created attachment 768436 [details]
evo bt

Description of problem:
evolution copies calendar synchronously

Version-Release number of selected component (if applicable):
evolution-2.32.3-9.el6.x86_64
evolution-data-server-2.32.3-7.el6.x86_64

How reproducible:
didn't try to reproduce

Steps to Reproduce:
1. have a local calendar with some data and empty caldav calendar
2. right-click the local calendar, select "copy", select caldav calendar, confirm
3.

Actual results:
evo UI doesn't respond till the copying is over

Expected results:
evo performs copying in the background with progress indication in status bar

Additional info:
Comment 1 David Jaša 2013-07-03 15:56:51 EDT
Created attachment 768437 [details]
e-c-f bt
Comment 2 David Jaša 2013-07-03 15:57:20 EDT
Created attachment 768438 [details]
e-a-f bt
Comment 3 Milan Crha 2013-07-04 04:23:47 EDT
That's true, many calendar operations are done synchronously, on the main thread. It's to be done in upstream first (and is in my long term to-do). If you want, then I can do this particular function first and do the rest in upstream only, when the time comes; otherwise I'd just close this.
Comment 4 Milan Crha 2013-07-08 11:30:50 EDT
Let's do not do this, and wait for the upstream, when it's fixed. Only note that a backport from an upstream to rhel6.5 is undoable, due to move between 2.32.3 and 3.9.4 (current git master).

Note You need to log in before you can comment on or make changes to this bug.